Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Got the Blazer's 400 sbc fired up!!!

Discussion in '1969-1972 K5 Blazer | Truck | Suburban' started by Yukon Jack, Mar 17, 2007.

  1. Yukon Jack

    Yukon Jack 1/2 ton status

    Joined:
    Jul 25, 2002
    Posts:
    1,984
    Likes Received:
    0
    Location:
    Rose Hill, KS
    :saweet: :saweet: :saweet:

    Got the rebuilt 400 sbc fired up in my Blazer this afternoon. Sounds really good even through the existing glasspacks. Still a bit to do to be able to drive it but finally fired up!!!!!!

    Doesn't look like the alternator is working, I have a short in the wiring that controls some of the outside lights and dash and the temp gauge may be off a bit, but she runs!!!!!!

    Here's an audio file of her running

    http://www.yuk0njack.com/audio/blazerstartup.mp3
     
    Last edited: Apr 25, 2009
  2. GotLabs

    GotLabs 1/2 ton status GMOTM Winner

    Joined:
    Jul 30, 2005
    Posts:
    2,795
    Likes Received:
    0
    Location:
    Transient, USA
    Sweet! Audio is cool, but video is soooo much better.:D
     
  3. Mreetz

    Mreetz 1/2 ton status

    Joined:
    Jun 26, 2001
    Posts:
    1,282
    Likes Received:
    0
    Location:
    Subs of Denver, Colorado
    I put a 400 in mine last year, really likin it!!
     
  4. CDA 455

    CDA 455 3/4 ton status

    Joined:
    Jun 2, 2006
    Posts:
    8,598
    Likes Received:
    0
    Location:
    43rd State
    Rock and roll :waytogo: !!
     
  5. KingDuramax

    KingDuramax 1/2 ton status

    Joined:
    Jan 17, 2006
    Posts:
    451
    Likes Received:
    0
    Location:
    NY 14701
    Wont be long now for you.
     
  6. Yukon Jack

    Yukon Jack 1/2 ton status

    Joined:
    Jul 25, 2002
    Posts:
    1,984
    Likes Received:
    0
    Location:
    Rose Hill, KS
    Still not driveable so audio is all your gonna get now, but I will be sure to do a video when it is driveable.

    Cracked my heater core at some point while the motor was out plus gained a short somewhere in my wiring harness. Also have a bad alternator I'm guessing. Gonna buy new engine bay harnesses and step up to an internally regulated alternator.

    Had to fire it up a few times today, fires right up and sure idles nice. Hate to say it but I kinda of like the glasspacks. Gives it that 70's sound. They will be replaced as I won some mufflers from Mudhog a couple years ago.
     
  7. Burt4x4

    Burt4x4 3/4 ton status

    Joined:
    Feb 17, 2000
    Posts:
    6,854
    Likes Received:
    0
    Location:
    California (Modesto area)
    YYYYYYYYYYYEEEEEEEEEEEEHHHHHHHHHHHAAAAAAAAAAAFireitUp!!!!
    Sweet!
     

Share This Page