Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

GRRRRR!!! I'm sick of electrical issues!!!!

Discussion in 'The Garage' started by colbystephens, Feb 20, 2007.

  1. colbystephens

    colbystephens 1 ton status GMOTM Winner

    Joined:
    Feb 24, 2005
    Posts:
    10,924
    Likes Received:
    20
    Location:
    Oregon
    ok, went out to my truck, started up just fine everything works, turn on the headlights and only get marker lights. what's up with that? i tried a second light switch, all the fuses are good and i don't think that both headlights would go out at the same time. any thoughts???
     
  2. Jason4x4

    Jason4x4 1/2 ton status

    Joined:
    Nov 5, 2006
    Posts:
    4,505
    Likes Received:
    6
    Location:
    Chandler, AZ
    bad high beam switch? click it a couple times and see if they start working.
     
  3. W7NB

    W7NB 1/2 ton status

    Joined:
    Nov 9, 2006
    Posts:
    716
    Likes Received:
    0
    Location:
    Springtucky, OR
    Good answer!

    I'd bet on a bad high beam switch. I've had my lights go out completely when I switch from low to high and only come back on with a wiggle. Plan to replace it when I finish with the axle/lift stuff.
     
  4. 1BadK-30

    1BadK-30 1/2 ton status

    Joined:
    Feb 6, 2005
    Posts:
    817
    Likes Received:
    0
    Location:
    Phoenix, Arizona
    I know how you feel colby, I have the same problem and they just stoped working on me one day :(
     
  5. Russell

    Russell LB7 Tahoe Status Premium Member GMOTM Winner

    Joined:
    Jun 23, 2000
    Posts:
    7,921
    Likes Received:
    331
    Location:
    Fort McMurray, Alberta
    Why not just replace all the wiring?

    As far as I am aware, all the diesel specific stuff is in it's own seperate harness...

    Takes only a few hours, then suddenly you have all new wiring, which will fix your wiper switch, light and ignition issues... Fix that mess you've made properly! :D
     
  6. colbystephens

    colbystephens 1 ton status GMOTM Winner

    Joined:
    Feb 24, 2005
    Posts:
    10,924
    Likes Received:
    20
    Location:
    Oregon
    i think it is that high-beam switch. i got them working, drove out to where i needed to be, came back to my truck they wouldn't work. screwed w/ it some more and thought it was a ground issue. great, that's easy to fix. well, shut off my truck again and had the same problem only wiggling my grounds didn't work. screwed w/ it for a while and got nothing. then i fired up my truck and figured i'd use my auxiliary lights to get me home, and as soon as i turned the truck on the lights came on... wierd. anyway, it sux. guess i'll try the high beam switch tomorrow evening.

    wiring is my spring break project! :) i think i'm going to relocate my fuse box... :D
     

Share This Page