Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Guys, help w/ washer fluid.

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by TXsizeK5, Sep 7, 2001.

  1. TXsizeK5

    TXsizeK5 1/2 ton status

    Joined:
    Aug 26, 2001
    Posts:
    2,518
    Likes Received:
    0
    Location:
    College Station, TX
    I have window washer fluid but it won't come out? whats the deal? can you guys help me. I could prolly figure it out but I'm getting busier w/ school. if youg uys can help me out that woudl be aweosme.! thanks!

    6in 87' K5 w/ 35" BFG muds.
    Kn filter

    What I need: 4.57 gears, limited slip front, auto locker in the rear, Force2 Catback, rear springs, SSR's
     
  2. coopertwpk

    coopertwpk 1/2 ton status

    Joined:
    Mar 18, 2000
    Posts:
    478
    Likes Received:
    0
    Location:
    Spring Valley Lake Ca.
    check first to see if the pump works its behind the tank,if not mine wouldnt work because of the intermitant control was bad (its mounted to the steering column under the dash plate)it has aluminum fins replaced it now it works.

    88k5 silverado w4"lift <font color=orange>d44 and corp14ff</font color=orange> with 4.56s
     
  3. TXsizeK5

    TXsizeK5 1/2 ton status

    Joined:
    Aug 26, 2001
    Posts:
    2,518
    Likes Received:
    0
    Location:
    College Station, TX
    How do i check the pump?

    6in 87' K5 w/ 35" BFG muds.
    Kn filter

    What I need: 4.57 gears, limited slip front, auto locker in the rear, Force2 Catback, rear springs, SSR's
     
  4. 87K54WD

    87K54WD 1/2 ton status

    Joined:
    Mar 23, 2000
    Posts:
    105
    Likes Received:
    0
    Location:
    Texas
    I had the same problem. It turned out to be this valve looking thing that goes between the hose and the pump. It was a small part that would fit in the palm of a baby's hand. Now it works great. As for checking the pump, I had someone hit the switch while I listened near the reservior for the pump to start working. Another possible problem is clogged lines. One way to tell would be to buy some clear tubing like at Walmart for a fish tank or something and attach it to the valve I spoke about above and have someone hit the switch to see if anything comes out. If so, then you know the pump and valve works and it is the lines after that point. Try that valve though, I was frustrated as heck. Decided to replace that valve with a new one at the dealership (maybe less than $5 or $10) and it works like a charm now.
     
  5. TXsizeK5

    TXsizeK5 1/2 ton status

    Joined:
    Aug 26, 2001
    Posts:
    2,518
    Likes Received:
    0
    Location:
    College Station, TX
    Is the valve easy to replace yourself? Can you desribe more what it looks like and where exactly its located? Thanks

    6in 87' K5 w/ 35" BFG muds.
    Kn filter

    What I need: 4.57 gears, limited slip front, auto locker in the rear, Force2 Catback, rear springs, SSR's
     
  6. 87K54WD

    87K54WD 1/2 ton status

    Joined:
    Mar 23, 2000
    Posts:
    105
    Likes Received:
    0
    Location:
    Texas
    When you take the reservoir off, it is going to be on the bottom, right behind the reservoir. You have to take it off to see it and the pump itself. You will see where the electrical lines run along the inside fender to the pump. You can miss the valve because it sort of sits or snaps into the reservoir to keep it from moving around. It will look like a minature fuel filter with molded line coming out of both ends. My orignal was green and pink. The GM replacement was all black or grey. It's an easy fix. Hope it works for you too.
     
  7. coopertwpk

    coopertwpk 1/2 ton status

    Joined:
    Mar 18, 2000
    Posts:
    478
    Likes Received:
    0
    Location:
    Spring Valley Lake Ca.
    Im not sure the his has a valve mine didnt it just has the pump that plugs down into the tank ,I just unplugged mine and jumped 2 wires to it off of the battery youll feel it start up or just hook a wire tester into the pump wires if it lights up youll know its the pump also check to see if the nozzles at the wipers arent clogged.

    88k5 silverado w4"lift <font color=orange>d44 and corp14ff</font color=orange> with 4.56s
     

Share This Page