Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Had some technical problems at the Mud Bog races!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by bigerik, Mar 18, 2001.

  1. bigerik

    bigerik 1/2 ton status

    Joined:
    Feb 24, 2001
    Posts:
    184
    Likes Received:
    0
    Location:
    Sonoma County, CA
    I didn't do too well at the mudbog races. TH350 in the Blazer isn't putting power to the ground and the Black Truck had its NP208 pop out of 4Hi in the middle of the race (doh!). I didn't qualify for the finals. I also got the lane that got torn up by some huge 6X6 5 ton military dump truck in the 6 cylinder class that almost got stuck and ruined the lane and ruined the race for half the trucks (thanks, buddy!). Also, the big blocks sort of dominated. Basically, I got my butt kicked! I'll be back with a new NP208 t-case and having fixed my mysterious TH350 problem (please see my other postand give me tech ideas/advice--I think I need a Jet Performance TH350).
     
  2. xplosuv

    xplosuv 1/2 ton status

    Joined:
    Mar 9, 2001
    Posts:
    515
    Likes Received:
    0
    Location:
    Sacramento, CA
    Hey man sorry to hear that. Theres always next time.

    If you cant go over it...GO THROUGH IT !!!
    75 Jimmy 11" lift with 40's
     
  3. BadDog

    BadDog SOL Staff Member Super Moderator Author

    Joined:
    Feb 24, 2001
    Posts:
    7,777
    Likes Received:
    11
    Location:
    Phoenix, AZ
    Oh man, too bad. I think on a rig like your's, I'd be looking for a TH400/NP205 and building on that.

    Bad Dog

    85 K30 CUCV, 350 TBI, TH400, NP205, D60/C14, 4.56
    Coming soon: 4" lift, 40" tires, massive cutting, shorter wb and rear overhang.
     
  4. bigerik

    bigerik 1/2 ton status

    Joined:
    Feb 24, 2001
    Posts:
    184
    Likes Received:
    0
    Location:
    Sonoma County, CA
    That's good advice. I think I'll start lookin' around for a TH400/NP205. I have a TH400/NP208 in my other truck and that tranny rocks. Did you check out my post on why the TH350 isn't putting power to the ground? If I floor the throttle on the pavement, the tach revs up to almost 4000 rpm but won't stay there. The truck just refuses to accelerate quickly for more than a few seconds, and even though I had an offroad/RV shift kit installed, it has a wimpy shift; in fact, it sounds like it's going to bog, die or even break!
     

Share This Page