Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Hard Shifts

Discussion in 'The Garage' started by bigbluesuburban, Oct 17, 2006.

  1. bigbluesuburban

    bigbluesuburban 1/2 ton status

    Joined:
    Feb 8, 2006
    Posts:
    1,362
    Likes Received:
    0
    Location:
    Constant State of Perpetual Anger
    89 Sub w/T400...

    From the day I bought the truck it has shifted hard. The seller had told me that he when he owned it he had a shift kit installed, so I really didn't think anything of the harder than normal shifting. But recently it started shifting Harder and Harder. I also noticed that my shift points have been moving on up the speedo. It was shifting into 2nd at about 27mph and wouldn't get into 3rd until 56mph, which is way high for normal driving. It was getting old real fast. And recently putting it in gear from Park has made for some HARD HARD HARD shifts.

    So today I checked my fluid level and it was AOK. I just couldn't figure out what was going on.

    WELL... It was the little piece of rubber hose that attaches to the Modulator. It was cracked wide open. I went and scavenged a piece of fuel line and slipped it in place... and guess what? It shifts perfectly.

    I am going to replace my Modulator because there was a little tranny fluid in the vacuum line, but other than that. It works perfectly now.

    I am just sharing this info and I hope it helps someone out there later on.
     
  2. mudbog42

    mudbog42 1/2 ton status

    Joined:
    Jul 16, 2006
    Posts:
    452
    Likes Received:
    0
    Location:
    Florida for now
    Mine shifts really hard too, like if I give it enough gas it will screech the tires when it shifts.

    Where is this modulator and line at?
     
  3. bigbluesuburban

    bigbluesuburban 1/2 ton status

    Joined:
    Feb 8, 2006
    Posts:
    1,362
    Likes Received:
    0
    Location:
    Constant State of Perpetual Anger
    The modulator is on the passenger side of the trans just past the bellhousing. It is usually cylinder shaped and about the size of a tuna can. The line runs into the side of it and should be just a short piece of flexible line and a hard line up to the motor.

    Hope this helps
     
  4. mudbog42

    mudbog42 1/2 ton status

    Joined:
    Jul 16, 2006
    Posts:
    452
    Likes Received:
    0
    Location:
    Florida for now
    Cool I'll check that out tomorrow
     
  5. mudbog42

    mudbog42 1/2 ton status

    Joined:
    Jul 16, 2006
    Posts:
    452
    Likes Received:
    0
    Location:
    Florida for now
    Oh Well

    Ok It wasn't that easy for me,:doah: everything looked good so I'll just continue to screech my tires when I shift:D:haha:
     
  6. rafterman191

    rafterman191 Registered Member

    Joined:
    Aug 28, 2006
    Posts:
    54
    Likes Received:
    0
    Location:
    Indiana
    Weird, mine has been doing this too, 86 K5 w/ about 75K on it. 2nd gear mostly, on wet pavement, in just about breaks traction everytime.
     
  7. KGsK5

    KGsK5 1/2 ton status

    Joined:
    Aug 26, 2006
    Posts:
    343
    Likes Received:
    0
    Location:
    Havre de Grace, Maryland
    ive got a different problem with my 700r4... when it shirts from 2nd to 3rd, the engine revs and nothing gets to the ground. its like the trans is slipping... but it doesnt do it in any other gear or downshifting. maybe it is slipping? dont know very much about transmissions so any suggestions would be appreciated.
     
  8. rafterman191

    rafterman191 Registered Member

    Joined:
    Aug 28, 2006
    Posts:
    54
    Likes Received:
    0
    Location:
    Indiana
    That sounds like slipping to me. Filter, fluid check. May need a change of both.
     
  9. KGsK5

    KGsK5 1/2 ton status

    Joined:
    Aug 26, 2006
    Posts:
    343
    Likes Received:
    0
    Location:
    Havre de Grace, Maryland
    been doing it for the past 2-3 months since i got it. ive kept an eye on teh fluid and it looks new as it did when i first got it. oh and it does it worse when i hit the gas hard. and its always around 35-40mph.
     
  10. 76zimmer

    76zimmer Flyin Rat Premium Member GMOTM Winner

    Joined:
    Nov 14, 2005
    Posts:
    23,033
    Likes Received:
    1,347
    Location:
    Kzoo, Mi
    TV cable adjustment?
     
  11. KGsK5

    KGsK5 1/2 ton status

    Joined:
    Aug 26, 2006
    Posts:
    343
    Likes Received:
    0
    Location:
    Havre de Grace, Maryland
    ill give that a try...
     

Share This Page