Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Hard start in morning

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by badfish4tail, Oct 17, 2005.

  1. badfish4tail

    badfish4tail 1/2 ton status

    Joined:
    Mar 1, 2005
    Posts:
    1,684
    Likes Received:
    1
    Location:
    Long Beach
    Okay for the last week i am having a hard time starting my 91 K5.
    I seems like it is not getting gas, now with that said i have already replaced the fuel pump, sender, filter, and relay about 3 month ago. When i crank it will start and rpm's go up then fall right back down. After doing this for about 5 min or so it will finally stay on and i go on my mary way. It only does this in the morning for some reason. It's fine for the rest of the day. I just changed the fuel filter again thinking something was cloged, but that didnt work. Any ideas of what could be going on? Is there a fuel pressure regulator?
    Thanks for any help...Mario
     
  2. Bigg R

    Bigg R Registered Member

    Joined:
    Feb 21, 2005
    Posts:
    34
    Likes Received:
    1
    Location:
    Martinsville,Indiana
    I.A.C. out of whack!!!
     
  3. badfish4tail

    badfish4tail 1/2 ton status

    Joined:
    Mar 1, 2005
    Posts:
    1,684
    Likes Received:
    1
    Location:
    Long Beach
    Just talked to a tech friend of mine and told me the same thing :doah:
    Thanks for the quick respone :waytogo:
     
  4. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,980
    Likes Received:
    189
    Location:
    Roy WA
    Put a scanner on it and make sure engine temp before you start it first thing in the morning is reading close to ambient air temp.
     

Share This Page