Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Has anyone ever had this happen?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by fulltopblazer, May 21, 2002.

  1. fulltopblazer

    fulltopblazer 1/2 ton status

    Joined:
    Aug 1, 2001
    Posts:
    484
    Likes Received:
    0
    Location:
    Altus,Oklahoma 73521
    I was at the Canadian River just outside Amarillo,TX this weekend and was running down a trail that was a little to narrow for my blazer ( I was also runnind a little to fast ) and my left front tire hooked the side of the trail and jerked me around sideways. I tried backing up and straiting my tire and I couldn't, so I got out and my left front tire was turned all the way to the left and pushed up under the rocker. Anyway after taking some time to figure out what was wrong with it the bolt thet goes through the leaf springs had sheared off and let the axle slide back all the way to the first clamp on the sping pack. I still can't believe this happened the springs are less than 2 years old. I figure it would have broke a u-joint or axle stub before this happened. I wrapped a chain around the axle and hooked a come-along to the front bumper and pulled it back in to place and took it very easy back to camp and loaded it on the trailer and came home. I know this is long I was just wandering if anyone has ever had this happen?
     
  2. MudFrog

    MudFrog 1/2 ton status

    Joined:
    Feb 23, 2000
    Posts:
    3,236
    Likes Received:
    0
    Location:
    Daleville, Va
    I know this happened to Boss at Tellico a while back... I don't think his springs were even a year old.
     
  3. chevyfumes

    chevyfumes Court jester

    Joined:
    Feb 24, 2000
    Posts:
    38,584
    Likes Received:
    266
    Location:
    Watch for the muzzleflash!
    Did you put the springs on yourself and if so did you re-torque them at 100 and 500 miles, might be a dumb ? but it's a place to start...
     
  4. BurbinOR

    BurbinOR 3/4 ton status

    Joined:
    Feb 17, 2000
    Posts:
    5,829
    Likes Received:
    0
    Location:
    Oregon
    reedmit (Mitch) had that happen on our run to TSF back in March.........
     
  5. 1979Jimmy

    1979Jimmy 1/2 ton status

    Joined:
    Nov 14, 2001
    Posts:
    696
    Likes Received:
    0
    Location:
    Danville Ca
    does anyone know if you can buy new wraps that go around the leaf packs about 3/4 of the way up?
     
  6. Blazinaire

    Blazinaire 1/2 ton status

    Joined:
    Mar 17, 2002
    Posts:
    1,262
    Likes Received:
    0
    Location:
    Santa Maria, CA
    I have had that happen twice already in the 7 months (?) I've had my front springs on. Now every time that something feels funny, that is one of the first that I check. No biggy, easy fix.
     

Share This Page