Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

headlights = engine shut off

Discussion in 'The Garage' started by dheavychevy38, Feb 24, 2003.

  1. dheavychevy38

    dheavychevy38 1/2 ton status Premium Member

    Joined:
    Jan 6, 2003
    Posts:
    1,003
    Likes Received:
    1
    Location:
    Algonquin,illinois
    89 k5 35o tbi

    When or if you get it started and pull out the headlight switch the engine shuts off any help would be great /forums/images/graemlins/k5.gif
     
  2. ZonkRat

    ZonkRat 1/2 ton status

    Joined:
    Jan 16, 2003
    Posts:
    1,003
    Likes Received:
    0
    Location:
    Lawrence County Tennessee
    What kind of voltage in the battery?If your alt. isn't working right or the battery is not takeing a charge it could be theres not enough power to run everything.When the voltage drops below a certain piont the electronics turn themself off.I think this is around 9 1/2 volts. /forums/images/graemlins/thumb.gif
     
  3. dheavychevy38

    dheavychevy38 1/2 ton status Premium Member

    Joined:
    Jan 6, 2003
    Posts:
    1,003
    Likes Received:
    1
    Location:
    Algonquin,illinois
    nope got 12 volts cranks good if you get it to run runs good till you pull the switch plus it is so hard to get started you have to use starting fluid sometimes /forums/images/graemlins/1zhelp.gif
     
  4. dheavychevy38

    dheavychevy38 1/2 ton status Premium Member

    Joined:
    Jan 6, 2003
    Posts:
    1,003
    Likes Received:
    1
    Location:
    Algonquin,illinois
    got 12 volts
     
  5. chillywilly

    chillywilly Registered Member

    Joined:
    May 26, 2002
    Posts:
    70
    Likes Received:
    0
    Location:
    northern maine
    Look for a bad ground from engine to body. If it all looks ok try adding one. Buddy of mine painted his intake while i was doing headgaskets lost ground connection lol. I think his quit when brake lights were on.
     
  6. dheavychevy38

    dheavychevy38 1/2 ton status Premium Member

    Joined:
    Jan 6, 2003
    Posts:
    1,003
    Likes Received:
    1
    Location:
    Algonquin,illinois
    all the grounds are good we just replaced them
     
  7. One_Ton_k5

    One_Ton_k5 1/2 ton status

    Joined:
    Jan 30, 2003
    Posts:
    168
    Likes Received:
    0
    Location:
    St Paul Minnesota USA
    I had a similar problem on my 89 k5, check that your alternator has a good ground. I ended up adding a small ground strap from the ground post on the bacl of the alt to the main ground on the intake manifold.

    If you want I'll post a pic....
     

Share This Page