Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

headlights quit working!???

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by stevewix, Feb 20, 2005.

  1. stevewix

    stevewix Registered Member

    Joined:
    Dec 2, 2004
    Posts:
    83
    Likes Received:
    0
    my headlights quit working last night at the bar, everything else works, even the turn/brake/tail/4-way/marker lights. no bad fuses in the block under the dash, and interestingly enough, they come to life when i pull back on the high-beam switch on the column and hold. the hi beam switch doesn't make a prominent click, although i never paid attention to it's sound and feel before, it feels like nothing is happening. no notification of hi-beams or anything. as far as i can tell, there are no other fuses, relays or loose grounds.

    any ideas greatly appreciated. i'm confident it's either the headlight switch on the dash, or the dimmer switch on the tree.
     
  2. red77blazer

    red77blazer Registered Member

    Joined:
    Feb 13, 2005
    Posts:
    47
    Likes Received:
    0
    Location:
    Washington
    technician a says

    hi/lo beam switch


    by the way what year?
     
  3. 79Stomper

    79Stomper 1/2 ton status Premium Member GMOTM Winner

    Joined:
    Mar 4, 2004
    Posts:
    4,225
    Likes Received:
    19
    Location:
    Forest, VA
    Had a similar problem on my 79. I replaced the high/low beam switch and all was well.
     
  4. stevewix

    stevewix Registered Member

    Joined:
    Dec 2, 2004
    Posts:
    83
    Likes Received:
    0
    cool, that's what i was thinking. stomper it's an 85 m1009.
     

Share This Page