Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

heat ...or lack of

Discussion in 'The Garage' started by jones, Jun 1, 2004.

  1. jones

    jones 1/2 ton status

    Joined:
    May 17, 2004
    Posts:
    379
    Likes Received:
    0
    Location:
    IONIA,MI USA
    this one bugs me badly,guys.when it's warm,my heater blows hot,when it's cool,it does not.full of a-freeze,t-stat works(190* consistantly)i'm thinking my heater core is bad but there have been no symptoms to indicate that(sweet smell,fogging problems when heater is on.wet or even damp floor boards)less than 10k on rebuilt 350.NEW water pump at rebuild.HOWEVER!(I JUST REMEMBERED THIS)IT WAS GURGLING WHEN I BOUGHT THE TRUCK,BUT I DON'T RECALL HEARING IT LATELY. /forums/images/graemlins/thinking.gif /forums/images/graemlins/dunno.gif
     
  2. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    Is there a valve inline somwhere with the heater core hoses?
     
  3. jones

    jones 1/2 ton status

    Joined:
    May 17, 2004
    Posts:
    379
    Likes Received:
    0
    Location:
    IONIA,MI USA
    /forums/images/graemlins/dunno.gifnot that i know of.should there be?
     
  4. scoutillac

    scoutillac 1/2 ton status

    Joined:
    Feb 24, 2004
    Posts:
    423
    Likes Received:
    0
    Location:
    Spokane, Wa.
    [ QUOTE ]
    when it's warm,my heater blows hot,when it's cool,it does not

    [/ QUOTE ] You mean outside temp here right? Are you getting flow through the core? Maybe it's clogged.
     

Share This Page