Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

heater A/C issues *problem solved*

Discussion in '1992-Present Chevy & GMC models' started by MTChevy, Mar 18, 2006.

  1. MTChevy

    MTChevy 3/4 ton status Premium Member

    Joined:
    May 6, 2005
    Posts:
    7,141
    Likes Received:
    78
    Location:
    Great Falls, MT
    Hello everyone, I just bought a 92 silverado and the whole entire deal where you control the heater does not show up, the display is blank. Not only that none of the buttons do anything. The fan doesnt come on or anything. What are possible issues here? Thanks

    Cole
     
  2. HarryH3

    HarryH3 1 ton status Author

    Joined:
    May 31, 2000
    Posts:
    10,384
    Likes Received:
    2
    Location:
    Georgetown, TX
    First thing to do is check all fuses under the dash. If you're lucky, the system just isn't getting power.

    If that doesn't net anything you'll probably need a factory service manual to start troubleshooting. The central HVAC computer controls all sorts of relays and servo motors that control fan speeds, air control doors, etc. The newer systems are WAY more complex than in our older junk. They replaced lever, cables and vacuum doors will lots of expensive-to-replace electronics. :(
     
  3. MTChevy

    MTChevy 3/4 ton status Premium Member

    Joined:
    May 6, 2005
    Posts:
    7,141
    Likes Received:
    78
    Location:
    Great Falls, MT
    I'll start with fuses. I've been lucky with them before. *fingers crossed*
     
  4. MTChevy

    MTChevy 3/4 ton status Premium Member

    Joined:
    May 6, 2005
    Posts:
    7,141
    Likes Received:
    78
    Location:
    Great Falls, MT
    Well, it aint fuses, so im thinking its the unit itself.... I pulled it out of the dash, but how do i get the plug out of the back of the unit iteself???
     
  5. MTChevy

    MTChevy 3/4 ton status Premium Member

    Joined:
    May 6, 2005
    Posts:
    7,141
    Likes Received:
    78
    Location:
    Great Falls, MT
    ok I got the plug off, blew in it and the thing it plugs onto, put it all back together and everything works again, whew!
     

Share This Page