Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

heater/blower question

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by woods, Mar 16, 2005.

  1. woods

    woods Registered Member

    Joined:
    Feb 18, 2003
    Posts:
    73
    Likes Received:
    0
    So the heater/blower quiting working on my 88 blazer, haven't tried troubleshooting it yet. Whats the common problem and is there more then one fuse for the blower and where's it located. Also my truck heated up like normal not fast or quick.

    thanks
    woods
     
    Last edited by a moderator: Mar 16, 2005
  2. imiceman44

    imiceman44 1 ton status

    Joined:
    Aug 5, 2002
    Posts:
    15,160
    Likes Received:
    1
    Location:
    Sacramento, CA
    last time mine quit working the wire had fallen off, I just plugged it back in.
    maybe you are that lucky?

    iceman
     
  3. bablazer73

    bablazer73 1/2 ton status

    Joined:
    Apr 4, 2000
    Posts:
    3,363
    Likes Received:
    0
    Location:
    upstate ny
    It stopped working all together? does it have A/C? If it does, It's most likely the relay. Or maybe the motor itself. Easy to ck weith a test light. The realay is mounted on the heater box next to the resister
     
  4. nau81blazer

    nau81blazer 1/2 ton status

    Joined:
    Mar 6, 2004
    Posts:
    329
    Likes Received:
    0
    Location:
    Cincinnati, OH
    Check that the ground is not lose or else it might have been fried........like my old one:crazy:

    --Adam
     

Share This Page