Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Heater only blowing cold air ?

Discussion in 'The Garage' started by njonl, Dec 9, 2006.

  1. njonl

    njonl 1/2 ton status

    Joined:
    Jun 30, 2003
    Posts:
    128
    Likes Received:
    0
    Location:
    Northern CA
    My heater just recently started blowing only cold air on every setting. I took the glove box out to look at the control linkages and sure enough the temp adjuster linkage was off so I hooked it back up and it still wouldn't blow hot air. So now I took the hoses off of the heater core thinking that it might be clogged. I took an air nozzle and stuck it up the heater core inlet and blew some air through there and it seemed to flow freely. Next I stuck a water hose in there and the water seemed to flow through freely as well. I figured that wasnt the problem so I took the front piece of off the air box under the dash to look at the doors internally and all of them seem to be functioning properly with all of the vacuum hooked up correctly and working. Where should I look next ? Sorry that was a long one but there are a lot of details. Thanks!
     
  2. njonl

    njonl 1/2 ton status

    Joined:
    Jun 30, 2003
    Posts:
    128
    Likes Received:
    0
    Location:
    Northern CA
    And I forgot to add that I have a hose running from the top port of my water pump to the bottom nipple of the heater core and the top hose is running to the top of the radiator.
     
  3. njonl

    njonl 1/2 ton status

    Joined:
    Jun 30, 2003
    Posts:
    128
    Likes Received:
    0
    Location:
    Northern CA
    bump anybody ?
     
  4. ryoken

    ryoken Puppy Fabricator Premium Member GMOTM Winner

    Joined:
    Jun 13, 2003
    Posts:
    29,622
    Likes Received:
    1,376
    Location:
    Jersey Shore
    radiator is full?
     
  5. JEBSR

    JEBSR 1/2 ton status

    Joined:
    Dec 23, 2004
    Posts:
    1,541
    Likes Received:
    0
    Location:
    Clarksville, TN
    Is the engine warming up properly? If so once the engine is at operating temperature feel both lines at the heater core. Both should be very hot and the same temp. Let us know what you find.
     
  6. babyburb

    babyburb 1/2 ton status

    Joined:
    Oct 24, 2006
    Posts:
    2,344
    Likes Received:
    0
    Location:
    1H North of Dallas
    stuck thermastat? Fixed my problem. cost $10
    Good luck!
     
  7. 85-m1028

    85-m1028 1/2 ton status

    Joined:
    Apr 26, 2005
    Posts:
    485
    Likes Received:
    0
    Location:
    costa mesa california
    the routing should go from the crossover to the top "nipple" and the bottom one goes to the radiator. make sure those hoses are tight on that heater core side and check for leaks after you install them..
     
  8. diesel4me

    diesel4me 1 ton status Premium Member

    Joined:
    Jul 24, 2003
    Posts:
    17,547
    Likes Received:
    937
    Location:
    Massachussetts
    Mickey + Minnie??..

    Maybe mice built a nest next to the heater core,blocking the flow of heat into the cab?...trucks that sit any length of time around here usually have a few rodents living in the heater ducts!...:eek1: :doah: :crazy: ....
     
  9. neverendingproject

    neverendingproject 1/2 ton status

    Joined:
    Jul 24, 2005
    Posts:
    1,637
    Likes Received:
    0
    Location:
    Tulsa, OK
    Vaccum leak could cause teh heater vent not to open, and consequently only blowing outside air.
     
  10. njonl

    njonl 1/2 ton status

    Joined:
    Jun 30, 2003
    Posts:
    128
    Likes Received:
    0
    Location:
    Northern CA
    Ok here is an update for everybody that asked me questions.. I touched the heater lines and only one is warm and it is the one coming from the water pump. It seems as though all the correct doors are opening. I hope the front part of the heater box open so I can see the doors opening and closing. I'm running out of ideas.. and it's getting cold!!
     
  11. JEBSR

    JEBSR 1/2 ton status

    Joined:
    Dec 23, 2004
    Posts:
    1,541
    Likes Received:
    0
    Location:
    Clarksville, TN
    If only one line is getting warm then the heater core is clogged. Both lines should be the same or within a few degrees of the same temp
     
  12. gmc4cw

    gmc4cw 1/2 ton status GMOTM Winner

    Joined:
    Jul 19, 2006
    Posts:
    3,907
    Likes Received:
    0
    Location:
    west chester, Pa
    is the hose hotter close to the pump then it is by the heater core. I would unhook the hose from the radiator and run the truck to see if it is pumping through the core. maybe the water pump is clogged up at the port and only a trickle is getting through.:dunno:

    get the truck warm first so that you know the thermostat is open. get the hoses loose before you warm everything up so you don't have to fight with hot parts. good luck, don't burn yourself.
     

Share This Page