Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Heater Problem

Discussion in 'The Garage' started by 2High4U, Nov 19, 2005.

  1. 2High4U

    2High4U 1/2 ton status

    Joined:
    Aug 20, 2005
    Posts:
    542
    Likes Received:
    0
    Location:
    Felton Pennsylvania
    my heater works and the fan fast and all but it doesnt come out of the vents that quick my heater controls when i put it on heat doesnt work but it works at bi level and a couple of other places the lines look ok and ideas on how to fix this problem or what it is thats causing this?
     
  2. Leper

    Leper 1/2 ton status

    Joined:
    Feb 18, 2005
    Posts:
    4,437
    Likes Received:
    0
    Location:
    Dallas Baby!!!!
    Which vehicle?
     
  3. 2High4U

    2High4U 1/2 ton status

    Joined:
    Aug 20, 2005
    Posts:
    542
    Likes Received:
    0
    Location:
    Felton Pennsylvania
    its my blazer of course :D it still heats up when the window is down the slightest it gets cold really fast doesnt seem to warm things up very quickly heater core is good no air in lines im thinking that it has to do with the heater control but as I said before the lines going to it look fine i am missing a duct peice for the right side ac the remaining hole is covered by plastic and sealed up with a clamp... the air doesnt come very forcfully from the defroster vents ontop of the dash either although the fan sounds like its blowing normally
     
  4. diesel4me

    diesel4me 1 ton status Premium Member

    Joined:
    Jul 24, 2003
    Posts:
    17,568
    Likes Received:
    943
    Location:
    Massachussetts
    rodents??

    Check all the vacuum lines to the selector switch on the dash,and see if the vacuum canister dewhickey is closing the lever on the heater box that switches it from heat to defrost,and make sure you have vacuum in the main hose coming from the engine ,with it running of course!-it sounds like you have vacuum,because you say it works on some of the settings....

    If all that is working,then it might be the heater box "doors" might be stuck or have something blocking them from closing,like a pencil dropped down the defroster vent or something..I find a lot of crayons,straws,pencils and pens--and mice nests,dead mice,and decapitated mice in trucks and cars heater boxes around here!--especially if the vehicle has sat a lot..

    I had one Subaru my friends mother drove come into my garage with the dashboard shaking voilently whenever the heater was on "high" speed..I took the blower motor out,figuring it was junk,or the fan wheel was broken and throwing it out of balance..found 3 heads of mice inside the fan,and several broken blades out of it--and the rest of the mummified mice where blocking the airflow pretty much to all the ducts!..and a ton of the "stuffing" from under the rugs were packed into it!..

    I put them in a baggie and showed them to his mom--she was horrified!..and said "no wonder my cars stinks so bad!--I thought it was my wet dog that stunk the car up!" :eek1: --that must be good for your health--inhaling dead mouse particles! :thinking: :eek: --a quick trip to the boneyard for another blower motor,and all was well..oh yeah..the Subaru at the boneyard had a rats nest in it too-- :doah: :crazy:
     
  5. gravdigr

    gravdigr 1/2 ton status

    Joined:
    Apr 15, 2003
    Posts:
    1,129
    Likes Received:
    0
    Location:
    Tyrone, PA
    lol, that has to be one of the biggest run on sentences I have ever seen.
     

Share This Page