Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Heater Problem

Discussion in 'The Garage' started by babyburb, Dec 6, 2006.

  1. babyburb

    babyburb 1/2 ton status

    Joined:
    Oct 24, 2006
    Posts:
    2,344
    Likes Received:
    0
    Location:
    1H North of Dallas
    I am having a problem with my heater/defroster. The problem is they do not work............At all. Nothing blows except on A/C setting. I have also noticed that the engine temp does not rise very much after it heats up. Someone told me I have a termastat either stuck or someone took it out completely and that is why my engine fails to warm. That will be fixed tommorow. At $5 and maybe 30 minutes this is easy enough.

    What else could be the problem with the dash or defroster not blowing. Not worried to much about heater but having problems keeping Ice off windsheild. (The wife and kids would like the heater fixed though!)

    Thanks for the help guys.
     
  2. my88texastruck

    my88texastruck Registered Member

    Joined:
    Oct 9, 2006
    Posts:
    37
    Likes Received:
    0
    Location:
    Northern Michigan
    What year truck are we talking about here? Earlier models used cables for damper contol - broken cable? Later models used vacuum to control the damper.
     
  3. Cricket

    Cricket 3/4 ton status

    Joined:
    Nov 29, 2004
    Posts:
    8,224
    Likes Received:
    0
    Location:
    Colorado
    Have you looked under the hood at the blower motor housing to see if the power lead may be loose or unplugged?
     
  4. babyburb

    babyburb 1/2 ton status

    Joined:
    Oct 24, 2006
    Posts:
    2,344
    Likes Received:
    0
    Location:
    1H North of Dallas
    76 suburban

    Haven't had a chance to start troubleshooting. It just started getting colder down here in Texas so haven't needed it yet. I will start troubleshooting tommorow with the thermastat change. But keep the ideas coming. I need all the help I can get.
     
  5. Cricket

    Cricket 3/4 ton status

    Joined:
    Nov 29, 2004
    Posts:
    8,224
    Likes Received:
    0
    Location:
    Colorado
    Don't forget to check the fuse box.
     
  6. my88texastruck

    my88texastruck Registered Member

    Joined:
    Oct 9, 2006
    Posts:
    37
    Likes Received:
    0
    Location:
    Northern Michigan
    Being a '76, I'd look for a broken cable either at the dash or heater box. Are you feeling any resistance when you move the selector back and forth? When you say it has no defrost or heater is the fan still blowing when the selector is in that position?
     
  7. babyburb

    babyburb 1/2 ton status

    Joined:
    Oct 24, 2006
    Posts:
    2,344
    Likes Received:
    0
    Location:
    1H North of Dallas
    no resistance. the blower works and blows on the a/c selection but on defrost heater no fan at all. The wife claims there is a very small amount coming from under the dash in between the seats but I never could feel it. I've had my ear on the dash rying to listen for any sounds but nothing.
     

Share This Page