Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

heating up while towing hills

Discussion in '1969-1972 K5 Blazer | Truck | Suburban' started by borton, Oct 8, 2001.

  1. borton

    borton Registered Member

    Joined:
    Jun 4, 2001
    Posts:
    14
    Likes Received:
    0
    Location:
    Salt Lake City
    ok, here is what I have, an 89 burban, 350, a compucam by crane, a new radiator, water pump replaced ?, new heavy duty torque converter, and a recent tranny rebuild, same time as the cam. it has a 3" exhaust , but the cat is original with 200k+ miles on it.

    when I hook the trailer on and go to take a hill the thing heats up borderline redline, I hit the top and things cool down fast enough, and I have no problems when I'm not towing anything, even with the air on and a hot summer day in traffic, so what can I do to keep it from heating up like this, I'm going to replace the cat tonight, and I suspect it will make a diffrence in heat, and will definatly make a performance diffrence, but could it be causing it to heat up that much, if not what am I missing?
     
  2. Steve_Chin

    Steve_Chin 1/2 ton status

    Joined:
    Mar 6, 2001
    Posts:
    1,126
    Likes Received:
    0
    Location:
    Foster City, CA, USA
    The simple answer is that you're putting in more heat energy than you are rejecting until you reach that nearly redlined state. To reject more heat energy you need more air flow through the heat exchanger, more coolant medium flow through the heat exchanger, or a larger heat exchanger. Does the near-overheating condition get mitigated by turning the heater on? If so, then I'd guess that you need a larger radiator and possibly more air flow through it.

    Hmmm... Check the radiator and A/C condenser for bugs, brush, whatever and clean them out. That might help.
     
  3. chevyracing

    chevyracing 1/2 ton status

    Joined:
    Sep 8, 2001
    Posts:
    2,589
    Likes Received:
    0
    Location:
    Colorado
    Something else to think about is to check you timing. If that is wrong or your advance is not working right that could be a possible cause, especially pulling extra weight. Steve's idea's are the first step though. This may sound a bit weak, but if you are running a bit lean on the mixture that may also produce heat that may not be noticed until you pull extra weight as well.
    Good luck and let us know what you find out.

    John

    Like to go sloppin' 'round in da mud in a rapid fashion....=)
     
  4. borton

    borton Registered Member

    Joined:
    Jun 4, 2001
    Posts:
    14
    Likes Received:
    0
    Location:
    Salt Lake City
    well, I put in a 180 thermostat, and a new catalitic converter, took the same hill with the same load, but a cooler day and it barely got above 210, which is acceptable, I also found out that I was plenty rich on antifreeze, so since I bought the new water pump I tossed it in last night and now my water to antifreeze level is even less antifreeze. so I'm only good agains freezing down to about 10*f and I'll have to add some antifreeze after my trip to moab friday. and I'm looking at a new 4 core probably in the spring.
     

Share This Page