Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Help a sister out-Rear windshield wiper issue

Discussion in 'The Garage' started by NoAngel, Feb 5, 2005.

  1. NoAngel

    NoAngel 1/2 ton status

    Joined:
    Sep 19, 2001
    Posts:
    1,497
    Likes Received:
    0
    Location:
    Northampton,MA
    When I turn on the switch to turn on the rear wiper it makes this rrrrrrrrrrr sound and doesn't move. So I get out and go to the back of the vehicle and give it a gentle shove and it starts to work for about 4 wipes then stops and the sound rrrrrrrrrrr happens again.(so the motor isn't spent...right? Cuz it's trying to work) What the?
    any ideas on what is going on?
    With all the salt, sand and snow it's a pain in the @ss not to be able to see out the back.
    Thanks all!;)
     
  2. Jonny-K5

    Jonny-K5 1/2 ton status

    Joined:
    May 27, 2003
    Posts:
    1,654
    Likes Received:
    0
    Location:
    SoCal
    im guessing this isnt for a k5, since i've never heard of them having a rear window wiper. so what car/truck is this? sounds like its gummed up maybe
     
  3. stockk5

    stockk5 1/2 ton status Premium Member

    Joined:
    Apr 13, 2004
    Posts:
    2,035
    Likes Received:
    71
    Location:
    Cromwell, CT
    i would think its from the previous time you used it and then it freezes slightly even though that stuff has anti-freeze stuff in it cuz my windshield wipers do that, they get stuck, the only thing i can see is nothing.. so its gotta be ice.
     
  4. Grim-Reaper

    Grim-Reaper 3/4 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    7,385
    Likes Received:
    0
    Location:
    Atlanta
    Sounds like the splines on either the windshild wiper arm are stripped or the arm is loose or the splines on the motor are stripped depending on how it is built.


    I Don't mind helping with stuff like this but it would help if you posted the Vehicle info. This site is dedicated to a K5 Blazer (Fullsize 69-91) but plenty of knowledgable people on other vehciles. It was never equiped with a rear wiper. I asume this is a S series baby Blazer/Jimmy. I think the motor and workings are a single assembly on those. If its not the actaul arm stripped out you will probably need to replace to motor assembly to repair.
     

Share This Page