Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Help all my lights are messed up and i have a safety tomorrow

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by chris12, Sep 26, 2006.

  1. chris12

    chris12 1/2 ton status

    Joined:
    Apr 23, 2006
    Posts:
    267
    Likes Received:
    0
    Location:
    Forest Ontario, 1/4 hr from Port Huron Michigan
    HELp me everyone. The truck goes for a safety tomorrow and the lights are all messed up here is what i gathered.


    Tap Brake pedal- Radio light flashes

    turn right - all lights a working

    Turn left- radio light flashes, both taillights and licencse plate light flashes,(L) fender light flashes, grill lights flashes(L and R), left fender light wont flash

    Hazards- radio light flashes, taillights flash, grill lights flash (L,R), plate light flashes, (L,R) fender lights dont flashes.

    Lights Full pull - i get a buzzer but if i turn the knob buzzer stops, but then i loose the radio light, rear taillights work, front end ligths all work

    Runners- i get a buzzer but if i turn dial buzzer gowes away but loose radio light, tailights all work. plate light is on, grill lights on and side marker lights on both fenders a on.

    Reverse tailight revers works on both tailights, and no other ligths on, so im ok with the reverse.

    And

    if i press the brake peal i get a buzzer ad if i turn the ligth knob buzzer goes off but loose radio lights.


    OK i hope somone can help me out a si really need the help bad.. This k-5 is booked for safety and e-test tomorrow.
     
  2. chris12

    chris12 1/2 ton status

    Joined:
    Apr 23, 2006
    Posts:
    267
    Likes Received:
    0
    Location:
    Forest Ontario, 1/4 hr from Port Huron Michigan
    ttt need some help on the diagnoses here. even if you only know one . then its a start. Does anyone think it could be grounds.
     
  3. FlagBurb

    FlagBurb Registered Member

    Joined:
    Oct 3, 2002
    Posts:
    58
    Likes Received:
    1
    Location:
    Tucson, AZ
    I had some similar problems with my rear turn signals and my stop lamps and reverse lights. I cleaned the grounds for the rear lights and replaced the bulbs - that took care of my issues. Good Luck...
     
  4. chris12

    chris12 1/2 ton status

    Joined:
    Apr 23, 2006
    Posts:
    267
    Likes Received:
    0
    Location:
    Forest Ontario, 1/4 hr from Port Huron Michigan
    Im thinking i migth have the bulbs mixed up like the single and the double filiment mixed up im going to go check that and some grounds and see what happens
     
  5. chris12

    chris12 1/2 ton status

    Joined:
    Apr 23, 2006
    Posts:
    267
    Likes Received:
    0
    Location:
    Forest Ontario, 1/4 hr from Port Huron Michigan
    Fix. Thanks for the help FlagBurb
     
  6. 1985_K5_Silverado

    1985_K5_Silverado 1/2 ton status

    Joined:
    Dec 21, 2005
    Posts:
    984
    Likes Received:
    0
    Location:
    Corn Country
    Bad grounds would be my first suspects also.
     

Share This Page