Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Help!! Burb won't start!!!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by crashfirepm53, Jul 5, 2004.

  1. crashfirepm53

    crashfirepm53 Registered Member

    Joined:
    Mar 14, 2004
    Posts:
    62
    Likes Received:
    0
    Location:
    florida
    Help!! Burb won\'t start!!!

    Trucks been running great.All of a sudden it turns over but fails to start.Plenty of spark.I take the fuel filter loose and no gas flow with the key on.Well she has 174,000 miles so she's due for a fuel pump.I put the new one in and turn her over fires right up.I let her run a bit and then shut her down.This morning again she won't start but turns over.Now i tested the old pump and she worked fine connected to a battery and the new one appeared fine also.The directions says low oil pressure or a faulty pressure switch can cause the fuel pump to shut off due to the oil pressure. /forums/images/graemlins/confused.gifThe wiring diagrahm does show the fuel pump wiring going thru the oil pressure switch.My manual doesn't even mention the oil pressure switch.Where is it at???Does this sound like the problem??Any advice??
     
  2. k20

    k20 3/4 ton status

    Joined:
    Sep 9, 2001
    Posts:
    5,068
    Likes Received:
    0
    Location:
    Mineral Springs, NC
    Re: Help!! Burb won\'t start!!!

    I believe the switch is one of the sensors in the block. You have two of them, one for the gauge and the other is for the computer. I dont remember which is which however. Someone else will have to answer that. I believe one of the sensors is near the distributor (possible both) and the other may be near the oil filter. The one near the filter may not be there on a sbc I may be thinkin of my bbc.
     
  3. skratch

    skratch 1/2 ton status

    Joined:
    Oct 28, 2003
    Posts:
    1,646
    Likes Received:
    0
    Location:
    Gorveport, OH
    Re: Help!! Burb won\'t start!!!

    I just replaced both on my rig when this happened, I wasn't sure which was which but after they were replaced it started fine for me.

    I think the one by the distributor is the one for the gauges though.
     
  4. crashfirepm53

    crashfirepm53 Registered Member

    Joined:
    Mar 14, 2004
    Posts:
    62
    Likes Received:
    0
    Location:
    florida
    Re: Help!! Burb won\'t start!!!

    Well I replaced the fuel pump relay and she has been running/starting fine ever since.Started about 7 times so far.It was the easiest one to replace.I'm gonna change the OPS later just for S#!t and giggles.
     
  5. skratch

    skratch 1/2 ton status

    Joined:
    Oct 28, 2003
    Posts:
    1,646
    Likes Received:
    0
    Location:
    Gorveport, OH
    Re: Help!! Burb won\'t start!!!

    That's good.

    I did have the relay come unplugged once, truck started fine for the first few times then it quit starting at a rest area in the middle of Iowa! /forums/images/graemlins/yikes.gif

    After a couple hours of troubleshooting my wife saw it unplugged and thought it might be a problem /forums/images/graemlins/doah.gifso much for me being the great mechanic I thought I was.
     

Share This Page