Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Help electrical problem.....

Discussion in 'The Garage' started by Moose, Apr 11, 2003.

  1. Moose

    Moose 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,062
    Likes Received:
    0
    Location:
    Glendale, Arizona
    Huys I need help. My 90 Suburban blows the fuse that runs the blower for the AC and the speedometer. I have replaced blower motor, both relays on the firewall and the switch. The speedometer works fine but if you turn on the air and turn it up it goes. What am I missing? Thanks /forums/images/graemlins/usaflag.gif
     
  2. BadDog

    BadDog SOL Staff Member Super Moderator Author

    Joined:
    Feb 24, 2001
    Posts:
    7,777
    Likes Received:
    11
    Location:
    Phoenix, AZ
    A short in the blower resistor pack or the wiring harness is all I can think of...
     
  3. zakk

    zakk 1/2 ton status

    Joined:
    Sep 21, 2001
    Posts:
    4,762
    Likes Received:
    0
    Location:
    San Jose CA
    does it blow immediately? if so, refer to Baddog's post /forums/images/graemlins/grin.gif
     
  4. Moose

    Moose 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,062
    Likes Received:
    0
    Location:
    Glendale, Arizona
    OK guys I worked on it this weekend now I am really confused. I checked the harness and stuff started the truck and let it run in the driveway for 15 minutes with the air on and blower on high and it worked fine. I didn't drive it around thoe. Hell I have no clue. /forums/images/graemlins/confused.gif
     

Share This Page