Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Help my speedo quit working and check engine light comes ON

Discussion in 'The Garage' started by George_Pimpdaddy, Mar 28, 2005.

  1. George_Pimpdaddy

    George_Pimpdaddy 1/2 ton status

    Joined:
    Oct 17, 2002
    Posts:
    1,306
    Likes Received:
    1
    Location:
    Edmonton Alberta Canada
    :( hey i was driving home today when i noticed that my speedo in my 89 blazer quit then shortly after the check engine light came on i pulled over and shut the truck off and checked everything under the hood and checked most fuses and electrial like other gages and interior lights. i drove the rest of the way home and stopped at my local NAPA shop and picked up a new rear seal for my transfer case cause my old one was leaking a bit i noticed. Could that have something to do with my speedo problem and if theres no speedo input to the computer would that trigger the check engine light??? im planning on putting in that new rear seal in the 241 tonight and change the engine oil as well as check the rest of the truck out also does anyone know how much oil the np 241 takes i know that it takes ATF. thanks for any help :dunno:

    :k5: 355/700r4/np241
    10bolts that need to go with a posi in the rear
     
  2. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    Probably what the issue was.

    VSS is speedo driven, if speedo quits working, VSS signal to ECM was likely lost.

    Pull the code(s) with a paperclip...if a VSS code, you know almost certainly why.
     
  3. HarryH3

    HarryH3 1 ton status Author

    Joined:
    May 31, 2000
    Posts:
    10,384
    Likes Received:
    2
    Location:
    Georgetown, TX
    I think the speedo on an '89 is mechanically driven, so check the speedo cable. If it is intact and properly connected, the gear at the t-case could be stripped.

    On that style of setup the VSS signal comes from the speedo, so when the speedo stops - the VSS signal goes away.
     
  4. big_black_blazer

    big_black_blazer 1/2 ton status

    Joined:
    Dec 19, 2004
    Posts:
    114
    Likes Received:
    0
    Location:
    Western Kentucky
    np 241 holds around 2 qts

    no speedo signal = no vss signal = orange light on dash... mine's been that way since october

    NAPA doesn't even have the cable in their paper catalogue, niether does Advance or O'Reiley's or Autozone.

    GM has it for like $35 or so
     
  5. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    Crawl under your truck and make sure the speed o cable is still connected to the xfer case. It may have just unscrewed its self. Fluid may also leak out of the place where it connects to the xfer case if the cable is disconnected so maby that will fix your leak too.
     
  6. George_Pimpdaddy

    George_Pimpdaddy 1/2 ton status

    Joined:
    Oct 17, 2002
    Posts:
    1,306
    Likes Received:
    1
    Location:
    Edmonton Alberta Canada
    i can only hope its a easy fix like that and thanks for all the info guys im planning on taking a look tonight ive been to bust from wrok to look yet. and i talk to a frined of mine who says that its either the speedo gear (how hard is that to replace???) or the cable. gonna look into it tonight peace :cool1:
     

Share This Page