Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Help! p/s pump pulley slipping

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Blazer79, Jul 29, 2002.

  1. Blazer79

    Blazer79 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,816
    Likes Received:
    0
    Location:
    Guatemala, Central America
    When I swapped my 454, I had to remove the pulley from the power steering pump because I had to fabricate some brackets to bolt it to the 454. Since then, when turning and standing still I got this whinning from the p/s pump. I thought it was going bad, but after carefully listening, it actually sounds like the pulley is slipping on the pump shaft.

    I was going to spot weld it, but a friend told me that it would become unbalanced and that would destroy the pump quickly. How should I fix this?

    Any help appreciated.
     
  2. m j

    m j 1/2 ton status

    Joined:
    Dec 28, 2001
    Posts:
    4,606
    Likes Received:
    0
    pull it and inspect it for evidence of slipping.
     
  3. Blazer79

    Blazer79 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,816
    Likes Received:
    0
    Location:
    Guatemala, Central America
    I marked the position of the pulley to the shaft, started it and steered a few times. The marks are off now, so there is evidence that it is slipping. Now how should I fix it?
     
  4. m j

    m j 1/2 ton status

    Joined:
    Dec 28, 2001
    Posts:
    4,606
    Likes Received:
    0
    IIRC that is a press fit pulley.
    you may have pooched the shaft
     
  5. K10ANDYKHAMNIC

    K10ANDYKHAMNIC 1/2 ton status

    Joined:
    Sep 17, 2001
    Posts:
    1,962
    Likes Received:
    0
    Location:
    Western CO
    please explain "pooched" ?
     

Share This Page