Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

help! problem with stalling/loss of power

Discussion in 'The Garage' started by 88GLAZER, Apr 23, 2003.

  1. 88GLAZER

    88GLAZER 1/2 ton status

    Joined:
    Nov 19, 2002
    Posts:
    111
    Likes Received:
    0
    Location:
    West Virginia
    I just recently installed headers on my truck and new exaust, After instalation I tested it out, and the truck ran like [censored], back firing and stalling. I found that I had cracked the porclin on one of the spark plugs. so I replaced it. Now the truck idles great, but has no power, significantly less than when I started. I dont think that the engine is getting enough fuel. I had taken my truck to school, and I could barly hit 70mph on a slight incline. and after 200 miles the truck started stalling. filally I left the damn thing in Hagerstown, MD and hoped in my girlfriends jeep. What the hell could it be!
     
  2. 87sm465np208

    87sm465np208 1/2 ton status

    Joined:
    Aug 28, 2002
    Posts:
    1,114
    Likes Received:
    0
    Location:
    illinois
    is this thing a TBI? my friends had a loss of power problem, we replaced the fuel filter and it was all good, his gas miliiage droped alot because he uses the full power of the 350 now with his foot to the floor. You couldnt even blow though the old fuel filter /forums/images/graemlins/shocked.gif.

    /forums/images/graemlins/usaflag.gif /forums/images/graemlins/truck.gif
     
  3. bryguy00b

    bryguy00b 3/4 ton status

    Joined:
    Apr 7, 2002
    Posts:
    5,587
    Likes Received:
    0
    Location:
    Rochester, N.Y
    im having those simalier problems..allthough mine seem to have gone away...but i have a holley carb on my 350...and i dont even have a feul filter! cuase the Q-jets have a internal one..when thye switched it..they never put an in-line one on...cause the holley doesnt have one. so i picked one up couple days ago i gatta put on there. that should help. also that STP fuel system cleaner seems to have helped it out osme to! mine idles and runs great now most of the time.
     
  4. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    No chance you screwed up the O2 sensor/wiring?

    Not always will you get a code when that happens.
     

Share This Page