Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

HELP...stumbling idle/accelartion

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by rcpilot, Nov 7, 2002.

  1. rcpilot

    rcpilot 1/2 ton status

    Joined:
    Feb 22, 2002
    Posts:
    507
    Likes Received:
    0
    Location:
    Central Cali
    engine intermittenly stumbles at idle while in gear.. place in neutural it stumbles less.. upon slow/mild accelartion it stumble a little and then sometimes heavely.. get on it hard and it goes away.. Have new control module..new distributor advance kit... Could it be my edelbrock needs rebuild?? /forums/images/graemlins/eek.gif
     
  2. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,976
    Likes Received:
    189
    Location:
    Roy WA
    Sounds like a vacuum leak or timing issue, at least in order of likelihood.
     
  3. Stoopalini

    Stoopalini 1/2 ton status

    Joined:
    Oct 17, 2000
    Posts:
    999
    Likes Received:
    0
    Location:
    Austin, Texas
    How long since a standard tune-up? (plugs, wires, cap, rotor, fuel filter, air filter, etc...)

    Has this been going on for a while? Could it just be bad gas from your last fillup?

    Thomas.
     
  4. white-rhyno

    white-rhyno 1/2 ton status

    Joined:
    Jan 27, 2002
    Posts:
    942
    Likes Received:
    0
    Location:
    Ellensburg Washington
    I had the same problem. Check to make sure the jets for your acceleratpr pump are not plugged. Jar the throttle to see if they squirt. One of mine wasnt squirting, pulled it apart and cleaned it. It helped alot.
     
  5. rcpilot

    rcpilot 1/2 ton status

    Joined:
    Feb 22, 2002
    Posts:
    507
    Likes Received:
    0
    Location:
    Central Cali
    I tuned it it recently all but wires...no vaccum leaks..both accelarter jets squirt equally..started about a week and a half ago.. I was towing a rental trailer to move and started noticing it..1 tank full ago.. started using Texaco gas then /forums/images/graemlins/eek.gif ... filled it up with super on Tuesday..I'm putting a carb cleaner in it tomorrow...
     

Share This Page