Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

HELP..WHY IS MY ENGINE VIBRATING????

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by wsudu, Feb 14, 2002.

  1. wsudu

    wsudu Registered Member

    Joined:
    Jun 30, 2000
    Posts:
    43
    Likes Received:
    0
    Location:
    Wichita, Kansas
    I started my truck the other day, and the whole damn thing vibrates a lot when you wrap it up just a little, maybe to 1400rpm. I checked the balancer, fine. I listened for anything unusual, nothing. It seemes to run fine, but It really vibrates. I mean if something really broke inside the engine, I would know it right, cause it runs fine. Any suggestions? Thanks Brian
     
  2. thatK30guy

    thatK30guy 1 ton status Premium Member

    Joined:
    Jan 12, 2001
    Posts:
    32,076
    Likes Received:
    55
    Location:
    .
    Could have a vacuum leak.
    Could be the choke is not working properly.
    Could be missing on a cylinder or two.
    Could be........?



    <font color=red>Only real men drive K30's!!!</font color=red> [​IMG]

    <a target="_blank" href=http://coloradok5.com/gallery/thatK30guy>The K30 Collection</a>
     
  3. DuneRunner

    DuneRunner 1/2 ton status

    Joined:
    Aug 1, 2001
    Posts:
    1,252
    Likes Received:
    0
    Location:
    Fremont CA
    Motor Mounts going out...
    could be......

    Later <font color=green>KEN</font color=green>
    Fremont, CA
    DANGIT it's not a bronco!
    <a target="_blank" href=http://community.webshots.com/user/kensk5>My Picts</a>
     
  4. Sparky

    Sparky 1/2 ton status

    Joined:
    Aug 20, 2000
    Posts:
    423
    Likes Received:
    0
    Location:
    San Antonio(summer) Texas A and M (school year)
    if it runs fine i would check the moter mounts. Does the engine torque over alot when you put it in gear or from drive to reverse?

    Sparky

    When all else fails... Check the blinker fluid.
    78 K-5
     
  5. bigblue

    bigblue 1/2 ton status

    Joined:
    Dec 6, 2000
    Posts:
    658
    Likes Received:
    0
    Location:
    southern california
    motor mounts, have someone look while you are holding the brake and gas at the same time....(not in front of the truck of course). If the engine raises up high you will know...

    Surfing is Life...
     
  6. BOWTIE

    BOWTIE 1/2 ton status

    Joined:
    Dec 28, 2000
    Posts:
    2,018
    Likes Received:
    0
    Location:
    Outside with the sawzall.
    maybe your sparkplugs are fouled up...

    <a target="_blank" href=http://community.webshots.com/user/bowtie1ton>My K5.</a>
    <a target="_blank" href=http://www.texasoffroad.net/galleries/members/midnight>http://www.texasoffroad.net/galleries/members/midnight</a>
     
  7. morphed86k10

    morphed86k10 1/2 ton status

    Joined:
    Jun 25, 2001
    Posts:
    463
    Likes Received:
    0
    Location:
    Reno Nevada
    I'll second the spark plugs being fouled as something to check. My motor was running fine when one dsay I started it and it was shaking at idle and anytime I was on the gas at low RPM, more gas made the shake worse. I was down on power too. A simple change of spark plugs and it runs smooth like it used to.
     

Share This Page