Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Help with glow plugs needed...

Discussion in '1982-Present GM Diesel' started by rocko, Sep 18, 2002.

  1. rocko

    rocko 1/2 ton status

    Joined:
    Jul 3, 2000
    Posts:
    3,380
    Likes Received:
    0
    Location:
    Ellsworth, Maine
    In the '83, when I turn the ignition switch, the glow plugs light will not come on, no click, and it's not allowing the truck to start.

    Don't know if this matters, but yesterday after the truck started and ran fine, the light would come back on.

    Any ideas? I'm new to diesel and am clueless.
     
  2. arveetek

    arveetek 1/2 ton status

    Joined:
    Mar 1, 2002
    Posts:
    722
    Likes Received:
    0
    Location:
    Granby, MIssouri, USA
    If you have the original style glow controller, you ought to have a thermo-switch screwed into the water jacket at the rear of the driver's side head with a large relay on the firewall. These systems don't work well and are expensive to repair. It sounds like your controller went south.

    You can bypass the controller by jumping the relay and energizing the glow plugs. One of the wires going to the relay ought to have 12+, I don't remember which. Ground out the other wire, and the coil will engergize. Keep the relay closed for about 10 seconds, and then shut it back off. This will allow you to start the truck.

    Upgrading to the '85+ glow controller is the best solution.

    Casey
     
  3. doctor4x4

    doctor4x4 1/2 ton status

    Joined:
    Jan 22, 2002
    Posts:
    1,450
    Likes Received:
    0
    Location:
    Los Angeles
    i agree with all he says except i only charge for 5 seconds not 10 i sent u a pm also
     
  4. OFFRDK5

    OFFRDK5 1/2 ton status Premium Member

    Joined:
    Oct 2, 2000
    Posts:
    1,881
    Likes Received:
    2
    Location:
    Central IL
    What kind of glow plugs are you running? Be careful with the manual switch. You don't want to have 8 mushroomed glow plugs!! I had the problem, not fun. I would suggest going up to the AG60s and using the switch. If you forget to turn the switch off with AG60s you are fine. Anything else you in trouble!!
     
  5. arveetek

    arveetek 1/2 ton status

    Joined:
    Mar 1, 2002
    Posts:
    722
    Likes Received:
    0
    Location:
    Granby, MIssouri, USA
    Yes, what he said! Use 60G plugs.

    Casey
     
  6. surg82k5

    surg82k5 1/2 ton status

    Joined:
    Feb 7, 2001
    Posts:
    416
    Likes Received:
    0
    Location:
    San Antonio,Texas
    I would agree with the bypassing the controler. That is what I have going on my blazer. I have tried replacing the controller and relat once but it is not worth the money to keep doing it. I would rather just push the button by myself and know when my glowpugs are on and off. Hope this helps, if you have anymore ? just email me.
    Sergio
     
  7. rocko

    rocko 1/2 ton status

    Joined:
    Jul 3, 2000
    Posts:
    3,380
    Likes Received:
    0
    Location:
    Ellsworth, Maine
    Thanks guys for all your info... that's what I did and it works great now.

    And thanks to BatmanJr for all his hard work in helping me do this.
     
  8. OFFRDK5

    OFFRDK5 1/2 ton status Premium Member

    Joined:
    Oct 2, 2000
    Posts:
    1,881
    Likes Received:
    2
    Location:
    Central IL
    So ya go the ag60s in and a switch? Cool.
     
  9. surg82k5

    surg82k5 1/2 ton status

    Joined:
    Feb 7, 2001
    Posts:
    416
    Likes Received:
    0
    Location:
    San Antonio,Texas
    havn't talked to you in a while... when did you get a vehicle witha 6.2L That is awsome. Did you swap it in or get another behicle all together...
    Sergio
     
  10. rocko

    rocko 1/2 ton status

    Joined:
    Jul 3, 2000
    Posts:
    3,380
    Likes Received:
    0
    Location:
    Ellsworth, Maine
    Hey Sergio.. you finally back in Texas? or are you Yankee-ized from your trip to New York? lol..
    I bought a 1983 Blazer w/ a 6.2l Diesel.. but turned around and sold it within a month... buying another K5.. go figure.. these things are addiction... but not as addicting as my wife.. /forums/images/icons/grin.gif /forums/images/icons/grin.gif /forums/images/icons/cool.gif
     

Share This Page