Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Help with Posi

Discussion in 'The Garage' started by offroadcowboy, May 29, 2004.

  1. offroadcowboy

    offroadcowboy 1/2 ton status

    Joined:
    Jan 29, 2004
    Posts:
    171
    Likes Received:
    0
    Location:
    Wittman,Arizona
    /forums/images/graemlins/1zhelp.gif How can you tell if there is something wrong with a eaton posi unit? I have one in my 12 bolt and when i have the steering turned all the way one side or the other i start moving slowly forward or reverse i am hearing a popping noise,grinding noise. /forums/images/graemlins/1zhelp.gif
    It also seems to ocassionally do this when moving forward or reverse at low speeds with the wheel slightly turned one way or the other . /forums/images/graemlins/1zhelp.gif
    Is this normal noise from a posi or is it need to be rebuilt/replaced. Could it be wheel bearings?Gears set up wrong?Any help is greatly appreciated. /forums/images/graemlins/ears.gif

    Thanks Jeff
     
  2. pauly383

    pauly383 Daddy383 Staff Member Moderator

    Joined:
    Jul 22, 2001
    Posts:
    16,217
    Likes Received:
    1
    Location:
    Mesa , Arizona USA
    Well if its an original 12 bolt eaton , then the wearable parts probably need replacing, if you caught it in time . /forums/images/graemlins/k5.gif
     
  3. offroadcowboy

    offroadcowboy 1/2 ton status

    Joined:
    Jan 29, 2004
    Posts:
    171
    Likes Received:
    0
    Location:
    Wittman,Arizona
    It was installed in feb at AZ Differentials . The guy i bought the blazer from told me it had lockers in it f/r but i believe it just posi's. The shop also appears to have broken a diff cover bolt and instead of extracting it they just gooped the broken bolt and hole with some type of gasket /permatech.
    I am just hoping that the noise/feeling is normal or if not then i want to figure it out and get it fixed.
    Thanks
    Jeff
     
  4. pauly383

    pauly383 Daddy383 Staff Member Moderator

    Joined:
    Jul 22, 2001
    Posts:
    16,217
    Likes Received:
    1
    Location:
    Mesa , Arizona USA
    If he said it had lockers though , maybe you have a lockright or something like that in there . I am waiting on thrust washers as mine are 30 years old and worn ( 73 12b in a 83 k5 ) causing my locker to lock/unlock too frequently lately . Did AZ differentials install it for you , or the previous owner ? Either way it would be good idea to pull the cover anyway and inspect it as well as change lube. Heavy truck in AZ ( anything bigger than 6000 lbs ), wouldn't hurt to change fluid twice a year anyway. Then youd know what was in there too /forums/images/graemlins/k5.gif
     

Share This Page