Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Help! Wont start!

Discussion in 'The Garage' started by 89Silverado, Feb 12, 2005.

  1. 89Silverado

    89Silverado Registered Member

    Joined:
    Dec 14, 2004
    Posts:
    6
    Likes Received:
    0
    Location:
    Connecticut
    I went to start my 89 Blazer tonight after I just drove it less than two hours before. I have never had any trouble with it untill now. After cranking it forever I went and smelled the exhaust. I didnt smell any gas at all. Also, I usually hear the fuel pump when I first turn on the key, and im not hearing it at all now. It does have an aftermarket starter/keyless entry installed, could my problem be there? I'm new to EFI, ive always owned and worked on carbed vehicles(no probes either) so Im not sure where to start, fuses, wiring, etc.

    Thanks!
    Tony
     
  2. sweetk30

    sweetk30 professional hooker Premium Member

    Joined:
    Nov 1, 2004
    Posts:
    25,526
    Likes Received:
    526
    Location:
    horseheads , ny 14845
    how many miles on it? and do you here the pump run? if no pump check pump voltage with key on and se what you get. and you need 2 people to test. the key off for about 10 sec then be ready and turn on it will cycle for about3-4 sec then off. and crank will be on all time. if no volts and over 80-90k then pump bad thats life span on average pump.
     
  3. dirtwarrior17

    dirtwarrior17 Banned

    Joined:
    May 14, 2004
    Posts:
    1,820
    Likes Received:
    0
    Location:
    Redding, CA
    If that doesn't work check the fuel filter.
     
  4. 89Silverado

    89Silverado Registered Member

    Joined:
    Dec 14, 2004
    Posts:
    6
    Likes Received:
    0
    Location:
    Connecticut
    I do not hear the pump run at all. The truck has 131K miles on it.

    Thanks!
    Tony
     
  5. sweetk30

    sweetk30 professional hooker Premium Member

    Joined:
    Nov 1, 2004
    Posts:
    25,526
    Likes Received:
    526
    Location:
    horseheads , ny 14845
    i work at shop. and if i wason this one i would do pump. sounds like all others i have done. p.s. you might need the gm tag id off sender before changing it. and if in rust belt expect lots of rust up there . and do a filter also.
     

Share This Page