Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

HELP!!!!!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 84BLAZER7, Jul 3, 2001.

  1. 84BLAZER7

    84BLAZER7 Newbie

    Joined:
    Jul 2, 2001
    Posts:
    1
    Likes Received:
    0
    Location:
    Iowa
    I NEED YOUR HELP. i HAVE AN 84 BLAZER AND THE INSTRUMENT LIGHTS DO NOT WORK. WHEN I TURN ON THE TRUCK THE FUSE AUTOMATICALLY BLOWS. ALSO THE SEAT BELT WARN. BUZZER DOES NOT WORK.THE BRAKE AND CHOKE AND DOME LIGHTS ALL WORK. I THINK THE EXTRA ENERGY THAT IS SUPPOSED TO GO TO THE BUZZER GOES TO THE INSTRUMENT LIGHTS THUS BLOWING THE FUSE. ANY SUGGESTION OR THOUGHTS YOU HAVE ARE MORE THAN WELCOME. HELP ME. (BY THE WAY IS THE BUZZER A SMALL YELLW PLASTIC THING WITH 3 WIRES COMING FROM EITHER END, I DON'T KNOW BECAUSE IT HAS NEVER WORKED)
     
  2. BlazerGuy

    BlazerGuy 3/4 ton status

    Joined:
    Apr 20, 2000
    Posts:
    9,206
    Likes Received:
    0
    Location:
    abcde
    I don't have a answer to your question, but for future reference don't type in ALL CAPS! It's harder to read and it means that your yelling.......and fill out your profile........

    Murphy's Laws on Life:
    "A bird in the hand is worth three Kleenex."
    <A target="_blank" HREF=http://www.K5.rockcrawler.com>http://www.K5.rockcrawler.com</A> *under construction*
     
  3. Grim-Reaper

    Grim-Reaper 3/4 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    7,385
    Likes Received:
    0
    Location:
    Atlanta
    Did you just install a stereo? People screw up all the time and try to use the factory light wire as a ground wire. Check that first, thats the usual place that you see these sorts of problems.
    Yeah dude caps is rude in a forum.

    It's not my damn planet monkey boy!
    <A target="_blank" HREF=http://communities.msn.com/OffroadK5s>http://communities.msn.com/OffroadK5s</A>

    Grim-Reaper
     
  4. Storm Trooper

    Storm Trooper 1/2 ton status GMOTM Winner

    Joined:
    Nov 24, 2000
    Posts:
    4,640
    Likes Received:
    1
    Location:
    Dillon Colorado, Hang'in in the mountains. Renting
    If you don't have a meter to go through and check out each component then I sugest that you try to figure out what items are on that fuse that don't work. Disconect each one, mark them so you don't forget which wires go where then put a new fuse in. If it blows, you didn't find all the items powered on that cucuit, keep checking. If the fuse does not blow then reconnect one item at a time until you find the one that blows the fuse and replace it. If the seat belt buzzer is on that cucuit, lift the carpet and look at the wires there. It's a good place to cause the wires to get a hole rubbed through and cause a short. good luck.

    [​IMG]<font color=red>[/b]"Rid'in HigH in my K5"[​IMG]
    ....[​IMG]<font color=blue>[/b]"6" Lift -<font color=purple>38.5's"[​IMG]....
     
  5. Grim-Reaper

    Grim-Reaper 3/4 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    7,385
    Likes Received:
    0
    Location:
    Atlanta
    Cut him some slack...he's new he didn't know.

    It's not my damn planet monkey boy!
    <A target="_blank" HREF=http://communities.msn.com/OffroadK5s>http://communities.msn.com/OffroadK5s</A>

    Grim-Reaper
     
  6. ChevyCaGal

    ChevyCaGal 3/4 ton status

    Joined:
    Dec 16, 2000
    Posts:
    8,158
    Likes Received:
    0
    Location:
    Sacramento, CA USA
    I had that happen to me when I was rewiring my stereo... I had a wire grounding that shouldn't have been. Check around really well for wires that lead nowhere... if you find some, then find where they are attached and fix them so they ground the right way, or remove them if they are not needed.... [​IMG]

    I removed my quote so gay, vegetarian, minority, eco-nazis who love Jesus, nuke spotted owls, vote Gore and smoke medical marijuana won't be offend.
     
  7. JunkYardCrawler

    JunkYardCrawler 1/2 ton status

    Joined:
    Sep 9, 2000
    Posts:
    575
    Likes Received:
    0
    Location:
    Tucson, AZ
    i had this happen to me but i don't have a seatbelt buzzer. mine was a short in my light switch. on the dimmer controll had melted and shorted out some how. just go throw all the wires on that fuse and find out witch one is shorting out.

    Going nowhere everybody is a Moto Psycho
    Got my wheels in motion and i got a path to beat
     
  8. 84_Chevy_K10

    84_Chevy_K10 Banned

    Joined:
    May 30, 2001
    Posts:
    17,669
    Likes Received:
    0
    Location:
    IL, USA
    You've obviously got a wire shorting directly if you're popping a fuse that quick. I'd check the stereo wire too.

    I didn't ground it the 1st time I put in my stereo...I hooked it up with the ignition (orange or yellow, can't remember) wire thinking that's what it was....so when I turned the key on, the parking lights came on! Took me a few months and another stereo install to realize what I'd done!

    Tim
    '84 Chevy K10, lifted, loud, fast, and 3/4 ton axles
     
  9. BlazerGuy

    BlazerGuy 3/4 ton status

    Joined:
    Apr 20, 2000
    Posts:
    9,206
    Likes Received:
    0
    Location:
    abcde
    Sorry, didn't mean to sound too harsh [​IMG]

    Murphy's Laws on Life:
    "A bird in the hand is worth three Kleenex."
    <A target="_blank" HREF=http://www.K5.rockcrawler.com>http://www.K5.rockcrawler.com</A> *under construction*
     
  10. riz

    riz 3/4 ton status

    Joined:
    Mar 7, 2000
    Posts:
    6,026
    Likes Received:
    0
    Location:
    Wisconsin
    <font color=purple> recent stereo work = blown fuses .......look there first with a check light .

    L8r,
    . Riz . <A target="_blank" HREF=http://www.geocities.com/rizmonkey>http://www.geocities.com/rizmonkey</A>
     

Share This Page