Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

help!!!!

Discussion in '1982-Present GM Diesel' started by MUDNUTT, Feb 18, 2002.

  1. MUDNUTT

    MUDNUTT 1/2 ton status

    Joined:
    Aug 1, 2001
    Posts:
    339
    Likes Received:
    0
    Location:
    Mn
    need some help! was driving my 94 k3500 dually with the 6.5t when the alternator went out, threw the belt and overheated the truck. i replaced the alt. and belt, then filled it back up with antifreeze and started it. when it fired i could not see behind the truck thru the clouds of white smoke and it idled like a gas motor with a big cam. i think i blew 1 or both of the head gaskets but im not sure because the exhaust didnt smell like coolant. anyone have any ideas???

    <font color=red>DRIVE IT LIKE YOU STOLE IT[​IMG]
    <a target="_blank" href=http://community.webshots.com/album/24975635VazeJOnxiI>SEE MY PHOTOS</a>
     
  2. Danno

    Danno 1/2 ton status

    Joined:
    Aug 4, 2001
    Posts:
    487
    Likes Received:
    0
    Location:
    Rockford, IL
    Check fhe oil for coolant, check your coolant level, check for bubbles in coolant while engine is running.

    White smoke doesn't sound good, though.

    1984 K5 Blazer 4x4 Silverado
    6.2L diesel, 700R4, 3.42 gears, 31x10.5" tires
     
  3. MUDNUTT

    MUDNUTT 1/2 ton status

    Joined:
    Aug 1, 2001
    Posts:
    339
    Likes Received:
    0
    Location:
    Mn
    checked the oil, dosent seem to be any coolant in it. coolant level seems okay but its hard to see if theres any bubbles in the coolant while running because the radiator has no opening. the cap is on the expansion tank.

    <font color=red>DRIVE IT LIKE YOU STOLE IT[​IMG]
    <a target="_blank" href=http://community.webshots.com/album/24975635VazeJOnxiI>SEE MY PHOTOS</a>
     

Share This Page