Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

hidro assist help

Discussion in 'The Garage' started by BADRED73-N-AZ, Jan 25, 2004.

  1. BADRED73-N-AZ

    BADRED73-N-AZ Registered Member

    Joined:
    Jan 26, 2002
    Posts:
    65
    Likes Received:
    0
    Location:
    AZ, United States
    having trouble every once and awhile usaly in a tight spot it want turn to the driver side. it is a WTO system. havent had it on very long. I have repeatly bled the system. I also have cooler and large filter on it.
     
  2. Bullet

    Bullet 1/2 ton status

    Joined:
    Mar 14, 2001
    Posts:
    1,222
    Likes Received:
    0
    Location:
    Abilene, Texas
    Try to elaborate more on what your trouble is, though it sounds like at idle your pump isn't provididng the ram with enough fluid.
     
  3. BADRED73-N-AZ

    BADRED73-N-AZ Registered Member

    Joined:
    Jan 26, 2002
    Posts:
    65
    Likes Received:
    0
    Location:
    AZ, United States
    it is not just at idle even if i put it in park and rev it up it takes both hands and hard core force to get it to move. but it only does this some of the time usualy in athight spot
     
  4. Shaggy

    Shaggy 3/4 ton status

    Joined:
    Dec 15, 2000
    Posts:
    6,737
    Likes Received:
    0
    Location:
    Los Banos, CA
    Did you mod the PS pump?
     

Share This Page