Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

High rev's in idle

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by BPS, Oct 20, 2002.

  1. BPS

    BPS Registered Member

    Joined:
    Mar 24, 2001
    Posts:
    28
    Likes Received:
    0
    Location:
    Sooke, BC, Canada
    High rev\'s in idle

    Seems these days that just as i fix one thing another one acts up. /forums/images/graemlins/shocked.gif

    My latest problem is that the truck once warmed up revs high, if it had a carb, I say the choke was stuck. It seems Ok when cold started - it's so quiet it sounds like a Toyota - once warmed the engine revs stay fairly hi - I can coast forever at 30mph without touching the gas and of course at lights I realy hear the engine.

    My o2 is fairly new ~1000 miles, fuel pump ~500 miles and fuel regulator ~10,000.

    Is there a set idle screw on these beasts that I can play around with?

    Tks
     
  2. Grim-Reaper

    Grim-Reaper 3/4 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    7,385
    Likes Received:
    0
    Location:
    Atlanta
    Re: High rev\'s in idle

    I would start with the basics and work your way up. Check for a vacuum leak. I have not messed with the TPI yet but I have read a few posts where the gasket between the throttle body and intake has formed leaks and caused simular problems to what your experiancing.
    Welcome to CK5
     
  3. Blazer_Boy

    Blazer_Boy 1/2 ton status

    Joined:
    Dec 16, 2000
    Posts:
    1,669
    Likes Received:
    0
    Location:
    Sioux City, IA, USA
    Re: High rev\'s in idle

    I'll second that. I remember when I had a vac line for the MAP sensor unhooked of a TBI cavalier. It idled real fast with it unhooked.
     
  4. Z3PR

    Z3PR Banned

    Joined:
    Mar 30, 2002
    Posts:
    19,217
    Likes Received:
    0
    Location:
    Everywhere
    Re: High rev\'s in idle

    I had a 85 Monte Carlo CL with a 4.3 V-6 TBI motor. At idel the RPM wouls go from around 1000 RPM to around 1500 RPM back and forth. It turned out to be a bad sensor.
     
  5. TXsizeK5

    TXsizeK5 1/2 ton status

    Joined:
    Aug 26, 2001
    Posts:
    2,518
    Likes Received:
    0
    Location:
    College Station, TX
    Re: High rev\'s in idle

    With my 305 i idled at 1500! Now wiht my new 350 I had a problem with rough rough rough idling kicking back from 600-1000 constantly... and when i rev it stays high and didnt drop for a bit. Changed the 02 and it helped but started actin up again turns out it was the EGR valve... replaced that badboy and now im reving 900 straight up... no roughness or variance in idle.
    Oh and... no idle screws to mess with... you've got fuel injection buddy... gotta love it but you gotta hate it at the same time... everyhting has to dow ith your vaccum and such. =/
     

Share This Page