Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

holley pro-jection help

Discussion in 'The Garage' started by limey, Jan 19, 2004.

  1. limey

    limey 1/2 ton status

    Joined:
    Dec 17, 2002
    Posts:
    121
    Likes Received:
    0
    Location:
    midland texal
    i just traded some work for a holley pro-jection system. i beleave it is the hole setup. the only problem is i cant find any instructions. i can only find instructions for the new units. this one only has Holley and fule controller on the computer. serial# I69a 09104. i dont think this one has halph the sensors if any one could scan the instructions i would apriciate it.
     
  2. mastercraftkpk

    mastercraftkpk 1/2 ton status

    Joined:
    Mar 12, 2003
    Posts:
    192
    Likes Received:
    0
    Location:
    Houston, TX
    Do a search for Pro Jection. You may have t go back a couple of years, but there is a reprint of the "instructions" here somewhere.

    /forums/images/graemlins/usaflag.gif /forums/images/graemlins/k5.gif
     
  3. bryguy00b

    bryguy00b 3/4 ton status

    Joined:
    Apr 7, 2002
    Posts:
    5,587
    Likes Received:
    0
    Location:
    Rochester, N.Y
    next time take the time and make sure thats readable /forums/images/graemlins/rotfl.gif

    if u find some insructinos though id be interested in them to, becuase i may be comin into this setup myself.
     
  4. bablazer73

    bablazer73 1/2 ton status

    Joined:
    Apr 4, 2000
    Posts:
    3,363
    Likes Received:
    0
    Location:
    upstate ny
    2 or 4bbl version? analog or digital? do you know which CFM option? I have the directions for the 900CFM 4bbl version.
     
  5. limey

    limey 1/2 ton status

    Joined:
    Dec 17, 2002
    Posts:
    121
    Likes Received:
    0
    Location:
    midland texal
    i just called holley and they told me it is the analog setup. it is a 2bbl. they told me the pink went to the starter terminal, the white is the -tach, yellow is fast idle, brown is temp sensor. red is ignition, all blacks are ground. and the red and green that are together go to the fule pump. but i have 2 relays and i forgot to ask if i hook up the fuel pump with the relays like the new setups.(now all i need it if the red and green from ecu go to activate the relay of straight to pump??)
     
  6. bablazer73

    bablazer73 1/2 ton status

    Joined:
    Apr 4, 2000
    Posts:
    3,363
    Likes Received:
    0
    Location:
    upstate ny
    According to my instructions, The red and green go to the low voltage, apply side of the relay for fuel pump.
     
  7. limey

    limey 1/2 ton status

    Joined:
    Dec 17, 2002
    Posts:
    121
    Likes Received:
    0
    Location:
    midland texal
    cool that what i needed. thanks a lot, hopefully i can limp it to my shop tonight and tell yall how it dose tomorrow. thanks again /forums/images/graemlins/thumb.gif !!!
     
  8. limey

    limey 1/2 ton status

    Joined:
    Dec 17, 2002
    Posts:
    121
    Likes Received:
    0
    Location:
    midland texal
    ok it took 4ever but i finally got every thing put back together and the pro-jection on. but the fuel pump dosent work.. i rember their was a post a long long time ago discussing what after marked pump could be used.. but i could no go back enough in the search to find it.... it need to be an external pump that run at 15psi. any ideas what vehicle had a similar pump. or if anyone has a part # of a pump. thanks
     
  9. Executioner

    Executioner 1/2 ton status

    Joined:
    Feb 22, 2000
    Posts:
    1,530
    Likes Received:
    0
    Location:
    Temp. Ft. Walton Beach Fl. home=Tucson, Az.
    put 12v directly to the fuel pump to make sure its
    the fuel pump, and not the wires/relay/ECU.
    All three are high failure items for the analog
    pro-jection.
     
  10. limey

    limey 1/2 ton status

    Joined:
    Dec 17, 2002
    Posts:
    121
    Likes Received:
    0
    Location:
    midland texal
    i checked the power at ther wires from the ecu and had 12+. and checked the relay and it is good. then i put the power strait to the pump and still got nuthing (wouldent hum vibrate or anything)
     
  11. Executioner

    Executioner 1/2 ton status

    Joined:
    Feb 22, 2000
    Posts:
    1,530
    Likes Received:
    0
    Location:
    Temp. Ft. Walton Beach Fl. home=Tucson, Az.
    What about ground(return power) ?
    Sounds like you may need a new pump. /forums/images/graemlins/frown.gif
     

Share This Page