Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

How F'ed am I?

Discussion in 'The Garage' started by Logan, Feb 11, 2005.

  1. Logan

    Logan Registered Member

    Joined:
    Feb 17, 2000
    Posts:
    93
    Likes Received:
    0
    Location:
    Fournier, Ontario, Canada
    Now that I'm out trucking all the time, the girl is at home with the Jimmy ('84, 350). She's just got her licence, so nothing's safer, right? Heh, Heh.

    We're slowly going through how to take care of a vehicle, adding oil, *CHECKING OIL*, what to do when warning lights go off, etc... But I'm talking to her last night, and she mentions that the Alternator light is on -- has been since she left for work today, and all the way back home...Maybe 15 miles total.


    "Oh, and it sounds like something's bubbling."


    *Groan* -- Sure enough, alternator/water pump belt is gone. I had a buddy come out and throw a new belt on... It apparently runs and sounds fine, but what should I worry about? It was only 10 mins. each way, and it was freezing outside all day, so I'm hoping it'll come out of it OK.

    And she wonders why she can't drive the Celica. ;)
    SPARKS BAD!
    LOW OIL BAD!
    NO TAILLIGHTS BAD!
    FLAT TIRE BAD!
    WARNING LIGHTS *BAD*!
    NO! NO! NO!
    -Al.
     
  2. SUBFAN

    SUBFAN 1/2 ton status

    Joined:
    Mar 23, 2003
    Posts:
    2,334
    Likes Received:
    0
    Location:
    Davenport, Ia
    She should probably drive the vehicle that is hassle free....
     
  3. mr_clean

    mr_clean 1/2 ton status

    Joined:
    Sep 21, 2003
    Posts:
    348
    Likes Received:
    0
    Location:
    Sacramento, CA
    Man, my wife pulled that on me once in our 98 Exploder... The serpentine tensioner (being the smartest part of the vehicle) decided it didn't want to be attached to such a POS anymore and jumped ship. Well she drove home about 10 miles with no serpentine belt. I got up the next day, shat my pants when she told me what happened, replaced the tensioner and belt and the thing ran fine. Of course I took it to the dealer and traded it in for a non-ford vehicle right away:whistle:, but it did seem to be ok...
     
  4. 84_Chevy_K10

    84_Chevy_K10 Banned

    Joined:
    May 30, 2001
    Posts:
    17,669
    Likes Received:
    0
    Location:
    IL, USA
    It'll be fine, I've done that lots of times with high RPM stunts. :)
     
  5. eclipse

    eclipse 1/2 ton status

    Joined:
    Jan 1, 2005
    Posts:
    1,245
    Likes Received:
    0
    Location:
    Sparks, NV
    I doubt 10 minutes in the winter it would have over heated. And I've driving around many times with a bad alternator. just runs off the battery.
     

Share This Page