Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

How I got to spend my night *Update w/pics*

Discussion in 'The Lounge' started by mtnman210, Dec 24, 2005.

  1. mtnman210

    mtnman210 1/2 ton status

    Joined:
    May 30, 2003
    Posts:
    3,880
    Likes Received:
    0
    Location:
    Northridge, Ca
    After working on the prokect truck all day yesterday and feeling like I was gonna die. I made a quick dinner and was just about to jump into bed. My dad comes in and says get up we're going for a drive. Well long sotry short it was my sisters first big road trip into the snow and she was on her way home. Since she does have a 4wd she borrowed my dads truck (94 Blazer). And about an hour and a half from home calls crying that the truck is broken. And the "BRILLIANT" guys that went with her spent 20mins trying to figure out how to open the hood so they were a big help when trying to find out what was wrong. So I get up and of course I have no gas in the blazer. So I go grab gas and pickup the tow dolly from from the shop. and off we go. Got out to her about 10pm. I don't think that dolly was touching the ground on the way out. Got there and found no belts and the alternator was completely melted. I'd never seen this one before. I've cooked my fair share but this was actually melted along with a bunch of the wiring harness. Had it loaded in ten mins and started back home. Dropped it the truck off at my dads shop and came home. Got into bed about 12:30. Gotta say though I love towing with the new th400 what a difference. and I've found out my steerting SUCKS!.

    looking at it this morning it's quite impressive. The whole alternator is melted internally but it also ground through the mounting bracket as well. and there was a decent fire because his hood is scorched pretty well

    [​IMG]
    [​IMG]
    [​IMG]
     
    Last edited: Dec 24, 2005
  2. darkshadow

    darkshadow 1 ton status

    Joined:
    Dec 6, 2003
    Posts:
    12,250
    Likes Received:
    0
    Location:
    C-eh-N-eh-D-eh
    strange, what the hell hapened?

    suprized it dident catch fire, good thing though
     
  3. mtnman210

    mtnman210 1/2 ton status

    Joined:
    May 30, 2003
    Posts:
    3,880
    Likes Received:
    0
    Location:
    Northridge, Ca
    It looks like it was on fire at some point. but atleast it never got going any bigger. The only thing we came up with last night in the dark was the the baring must have froze and the didn't know. which fried it and snapped the belts.
     
  4. rumbly truck

    rumbly truck 1/2 ton status

    Joined:
    Jul 4, 2005
    Posts:
    132
    Likes Received:
    0
    Location:
    utah
    The bearings in those csi suck. looks like somebody threw dirt on it to put the flames out. Summit used to sell an iceberg kit for them. It was the back half of the case, with heavy finning on the rectifier section. Supposed to pull lots of heat out of the case, to save the bearings. They suck to work on too. You have to solder the stator leads into the rectifier bridge, the old si series was bullet proof, easy to service, and had cheap parts. I guess to get about twice the amperage out of the same size case, you have to have a comprimise.
     
  5. beater_k20

    beater_k20 Banned

    Joined:
    Dec 9, 2003
    Posts:
    10,276
    Likes Received:
    0
    Location:
    Elkhart, IN
    i noticed the dirt on the valve cover, and didnt think much of it. after further reviewing the pics, that's definitely what happened. no other way to get dirt on top of the PS pulley.
     

Share This Page