Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Howdy all.

Discussion in 'The Garage' started by Brians89K5, Jan 18, 2006.

  1. Brians89K5

    Brians89K5 1/2 ton status

    Joined:
    Jan 4, 2006
    Posts:
    535
    Likes Received:
    0
    Location:
    Rialto Ca.
    Hello. My name is Brian. I've been lurking around and reading posts and catching up on my k5 knowledge. This is my 3rd K5. My frist was a 74 my second a 79 and this one is an 89. Its my first K5 with a computer.... Which... I don't think I like. Heh, besides that. I have a question. I rebuilt the rear brakes a coulple of weeks ago, bled everything and now the truck stops better, however, every once and a while my parking brake light turns on and wont shut off until I turn the engine off for a bit. My Parking brake is adjusted correctly and at the up position when this happens. Do the fuel injected k5's have any sensors on the brake system? I know it does not have Anti locks. The fluid in the resovoir is full and the truck still stops efficiently. So... Im stumped. Also, how many of you folks tow with your k5's? I have a 19 foot toy box that I take to glamis every once and a while and on this trip I was sucessfull in smoking my transmission. Anyone else have problems with the tranny overheating? Thanks a bunch for your time. Ill get some pictures posted soon as Im allowed to. Seems that Im not allowed to do much as a new member.


    ~Brian
     
  2. Leper

    Leper 1/2 ton status

    Joined:
    Feb 18, 2005
    Posts:
    4,437
    Likes Received:
    0
    Location:
    Dallas Baby!!!!
    The 700R4 is know for it's overheating. You should never pull anything in overdrive. For regular driving, you need to get a HUGE tranny cooler.
     
  3. Brians89K5

    Brians89K5 1/2 ton status

    Joined:
    Jan 4, 2006
    Posts:
    535
    Likes Received:
    0
    Location:
    Rialto Ca.
    That was the thing, I was in drive the whole time when it overheated. It may be the fact that I am also trying to pull 33 inch tires with stock gearing. *shrug* The ebrake thing is really driving me nuts though.

    ~Brian
     
  4. midnitewarya

    midnitewarya Sounds like a problem for future me. Premium Member

    Joined:
    Dec 1, 2002
    Posts:
    1,726
    Likes Received:
    20
    Location:
    SoCal
    I wouldn't worry about the ebrake thing. It's a sensitive system that can get very weird sometimes. Does it come on just as you go over 35mph? (your prob going a little faster, but when the speedo hits 35, it should be when it pops on) That is when the system does a test, and almost any mod or change to it other than the stock config can make it trip. To include bleeding the brakes. Mine does it, has done ever since the first day my dad bought it back in '90. We lived in the UK and had to modify the rear lights to comply with UK standards. For some reason, it tripped it. You can get it fixed by getting a new brake computer. But it really is not worth it.

    As far as the cooler goes. Go on down to NAPA and buy the biggest tranny cooler they got. The 700r4 runs very hot, it needs all the help you can give it. Tranny coolers aren't at all hard to put in, it should only take about an hour or so.
     
  5. Brians89K5

    Brians89K5 1/2 ton status

    Joined:
    Jan 4, 2006
    Posts:
    535
    Likes Received:
    0
    Location:
    Rialto Ca.
    It only comes on when I have to stomp on the brakes. then it stays on. Then again, sometimes it comes on when I barely use the brakes. I think I may just disconnect the light so It doesn't anoy me.

    ~Brian
     

Share This Page