Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Hub issues

Discussion in 'The Garage' started by RustyMule, Mar 28, 2005.

  1. RustyMule

    RustyMule Registered Member

    Joined:
    Dec 18, 2004
    Posts:
    73
    Likes Received:
    0
    Location:
    Westford, MA
    Anybody who has converted thier case (np203) and put on the selectable hubs (MM) have a problem with the big ass spring behind it? I went to check the bearing ajustment and found aluminum dust from the hub alllllll inside there. Apparently the spring and that big washer inside started spinning (or not spinning) and the spring chewed into the selectable hub. I'm not sure how it happened, but I may have put the spring in backwards. Who knows. My problem is that big washer that supports the spring is now destroyed. The hub and bearing are easily available but I can't find the washer anywhere. Junkyard doesn't have it either. Anybody know what I'm talkin about????
     
  2. pauly383

    pauly383 Daddy383 Staff Member Moderator

    Joined:
    Jul 22, 2001
    Posts:
    16,217
    Likes Received:
    1
    Location:
    Mesa , Arizona USA
    Take em off and go get some Warn locking hubs . You shouldn't have that problem again . I would spray off your bearings and inspect them amd regrease and reassemble :k5: :k5:

    You won't need a big spring and washer with these either , just remove all the stuff so you see the spindle locknuts and install the new hubs .
     
  3. RustyMule

    RustyMule Registered Member

    Joined:
    Dec 18, 2004
    Posts:
    73
    Likes Received:
    0
    Location:
    Westford, MA
    Cool. Now I have an excuse to buy more stuff. HEhehehe
    Thanks
     

Share This Page