Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

hubs are messed up??

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 82K5_6.5L, Feb 5, 2003.

  1. 82K5_6.5L

    82K5_6.5L 1/2 ton status

    Joined:
    Dec 4, 2002
    Posts:
    439
    Likes Received:
    0
    Location:
    Tucson, Az
    does anybody have a diagram or some picture to show how automatic rubs are..like the guts of them, because i recently took mine off to replace wheel bearings and it seems i put a piece in wrong..can somebody show me the exact step by step of where each piece should go? please..without this being fixed i have no 4wd and that really sucks!! /forums/images/graemlins/crazy.gif thanx
     
  2. R72K5

    R72K5 Banned

    Joined:
    Mar 5, 2001
    Posts:
    8,905
    Likes Received:
    0
    Location:
    central IL
    even though i doubt wil be very helpful: easy fix: swap to manual hubs and put sledghammer to the auto hubs

    reassembling auto hubs is straight forward, not very many parts, is a body and clip and washer deal, pretty much it

    good luck
     
  3. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    Gosh I have never installed a set of those Auto hubs. /forums/images/graemlins/blush.gif
    Every time I have taken them off I threw them away and replaced them with manual hubs. /forums/images/graemlins/thumb.gif
     
  4. Rob 85K5

    Rob 85K5 1/2 ton status GMOTM Winner

    Joined:
    Feb 17, 2000
    Posts:
    1,487
    Likes Received:
    0
    Location:
    Pensacola, Florida
  5. 82K5_6.5L

    82K5_6.5L 1/2 ton status

    Joined:
    Dec 4, 2002
    Posts:
    439
    Likes Received:
    0
    Location:
    Tucson, Az
    wow thank you for the pic..i am in the process of getting manual hubs, but i dont have the money at the time...i just want to have some sort of 4wd for now..i guess a few weeks ago when i replaced my wheel bearings, i put a piece in backwards or in the wrong spot..so hopefully this will work for now. thanks alot! /forums/images/graemlins/grin.gif
     

Share This Page