Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Hubs locked...

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by TXsizeK5, Apr 11, 2002.

  1. TXsizeK5

    TXsizeK5 1/2 ton status

    Joined:
    Aug 26, 2001
    Posts:
    2,518
    Likes Received:
    0
    Location:
    College Station, TX
    Driving on the street with the hubs locked my truck has some weird characteristics... its kinda wabbly and shakey and theres a LOUD droning like road noise type noise that comes when the hubs are locked... what could be wrong?
     
  2. Hossbaby50

    Hossbaby50 3/4 ton status

    Joined:
    Sep 1, 2001
    Posts:
    8,972
    Likes Received:
    0
    Location:
    Peoria, AZ
    I drove my dads F350 with the front hubs locked one time right after I had to get out of a nasty spot, and I hit the highway, and when I would get to 55+ MPH it would start to shack and wobble a little, and turn a little funny. If you are wobbling at slow speeds then something like the ball joints might be worn, or tie ord ends or something. I couldn't tell you for sure. Just a guess. Do you have a front locker or posi? If so that might have something to do with it.
     
  3. reddog64

    reddog64 1/2 ton status

    Joined:
    Nov 9, 2000
    Posts:
    3,325
    Likes Received:
    0
    Location:
    Federal Way, Washington
    um... dont drive with your hubs locked on the road then???
     
  4. 72THING

    72THING 1/2 ton status

    Joined:
    Nov 26, 2001
    Posts:
    501
    Likes Received:
    0
    Location:
    Ranburne, AL
    When you drive with your hubs locked, it's turning your axleshafts and ring & pinion and therefore turning your front driveshaft. So.. if your front driveshaft is at too much of an angle or out-of-balance then that could be the vibration you're feeling.

    Will
     
  5. Panther

    Panther 1/2 ton status

    Joined:
    Aug 31, 2000
    Posts:
    845
    Likes Received:
    0
    Location:
    South Jersey
    Check your front driveshaft. The slip joint was bad on mine when I got it and the whole shaft moved up and down about a half inch, bending at the middle. Don't know if the 208 has a slip joint front shaft, but check the shaft in general.
     

Share This Page