Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

hydro boost system

Discussion in 'The Garage' started by KGsK5, Dec 30, 2006.

  1. KGsK5

    KGsK5 1/2 ton status

    Joined:
    Aug 26, 2006
    Posts:
    343
    Likes Received:
    0
    Location:
    Havre de Grace, Maryland
    went out to the junkyard today and found an 80s K30 2wd with a 6.2 in it. i want to pull the complete hydroboost system. what exactly do i need to get so that i am sure that i ahve the entire system? just booster and master cylinder? or is there more to it?

    thanks
     
  2. k204dr

    k204dr 1/2 ton status

    Joined:
    Aug 27, 2004
    Posts:
    463
    Likes Received:
    0
    Location:
    TN
    technically the booster, hoses, and power steering pump, as it has two return lines. but you can T them after the ps gearbox if you need to.
     
  3. noahrob

    noahrob 1/2 ton status Author

    Joined:
    Nov 26, 2005
    Posts:
    1,878
    Likes Received:
    1
    Location:
    Santa Barbara
    I might have a hydro boost PS pump if you don't get it...
     
  4. makovai

    makovai 1/2 ton status

    Joined:
    Jun 6, 2006
    Posts:
    854
    Likes Received:
    0
    Location:
    oregon city
    thats where i scewed up. I got the hydro, m/c, and hoses, but at the time didn't realize the p/s pump was different.

    BTW....is the M/C actually different or are they the same as a regualr setup?
     
  5. k204dr

    k204dr 1/2 ton status

    Joined:
    Aug 27, 2004
    Posts:
    463
    Likes Received:
    0
    Location:
    TN
    the master cylinder is the same. you don't have to have to pump, just T your return line after the gearbox for the hydro to return to. thats how I have it setup on my stock scout ps pump. works just fine.
     
  6. mouse

    mouse 1/2 ton status

    Joined:
    Nov 10, 2003
    Posts:
    1,448
    Likes Received:
    0
    Location:
    Great Falls Mt
    I ran a "T" return line for about a year, and every once in a while, more often when it was cold out, the brake pedal would be slow to come back up after using the brakes.

    When I switched to TBI and installed a serpentine belt system I bought a remanned hydroboost pump/reservoir with the two return nipples (~$50) and haven't had the problem since.

    Others have reported similar problems when running a "T." Another bonus, the HB reservoir is bigger than the non-HB units.

    More info: http://coloradok5.com/forums/showthread.php?t=179887&highlight=hydroboost
     

Share This Page