Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

HYDRO CLUTCH PROBLEM NEED HELP

Discussion in 'The Garage' started by badassblazer03, Mar 21, 2004.

  1. badassblazer03

    badassblazer03 Registered Member

    Joined:
    Oct 2, 2003
    Posts:
    82
    Likes Received:
    0
    Location:
    Amherst, NH 03031
    I have an 82 blazer that I have recently put a hydraulic clutch in and now it is goving me problems. It is not disengaging the clutch. I have made sure the clutch master is lined up well with the pedal and we have bleed the system. How far is the slave cylinder supost to go out and is their some fix to this that I have not allready tried.
    -Stew /forums/images/graemlins/confused.gif /forums/images/graemlins/dunno.gif
     
  2. Burt4x4

    Burt4x4 3/4 ton status

    Joined:
    Feb 17, 2000
    Posts:
    6,854
    Likes Received:
    0
    Location:
    California (Modesto area)
    Bigger return spring?
    Just a guess /forums/images/graemlins/waytogo.gif
     
  3. badassblazer03

    badassblazer03 Registered Member

    Joined:
    Oct 2, 2003
    Posts:
    82
    Likes Received:
    0
    Location:
    Amherst, NH 03031
    finally got it, i was bleeding it wrong, thanks for the reply.
    -Stew
     
  4. Burt4x4

    Burt4x4 3/4 ton status

    Joined:
    Feb 17, 2000
    Posts:
    6,854
    Likes Received:
    0
    Location:
    California (Modesto area)
    Oh ya?
    How did that happen?
    Please tell me how to doit the right way.
    I will be doing this sometime next month /forums/images/graemlins/waytogo.gif /forums/images/graemlins/peace.gif
     

Share This Page