Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

I finally got ahold of the vehicle

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 86mission, Oct 30, 2002.

  1. 86mission

    86mission Registered Member

    Joined:
    Oct 16, 2002
    Posts:
    9
    Likes Received:
    0
    Location:
    Fairfax County, VA
    Hello folks.

    It is a 88 S10-Blazer, w/ 4.3 Liter EFI V6. 4-Speed Auto.

    I just got back from Ohio, and didn't notice any problems with the vehicle. Apparently they've been constantly fixing things as it went bad, last thing was an alternator I believe.

    Strangely, when I have the heater on, the ashtray/stereo system seem to get very hot, especially underneath the ash tray. Anyone else notice this? is this an issue?

    Now, what would I have to upgrade, in order to put some 33's on? or would 33's be excessive now that its not a K5? Anyone have pics of a S-10 Blazer w/ 33's and 4" lift?

    Also, this was kindof weird, inside the vehicle, on the glovebox, there was a "S-10 Tahoe" badge. Weird, I guess this is the confusion I was reading about on the "internet"

    Thanks!
     
  2. Mreetz

    Mreetz 1/2 ton status

    Joined:
    Jun 26, 2001
    Posts:
    1,282
    Likes Received:
    0
    Location:
    Subs of Denver, Colorado
    Sounds like a looose or cracked hose on your heating.
     
  3. tipoil

    tipoil 1/2 ton status

    Joined:
    Jul 30, 2002
    Posts:
    222
    Likes Received:
    0
    Location:
    canada guebec
    the "tahoe" is the trim level of ur truck.
     

Share This Page