Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

I got DW bad

Discussion in 'The Garage' started by Bhintz, Jun 15, 2005.

  1. Bhintz

    Bhintz 1/2 ton status

    Joined:
    Mar 28, 2003
    Posts:
    1,341
    Likes Received:
    0
    Location:
    Roswell, Ga
    so I finally got the K5 running after putting crossover and 56s spring up front went and took it for a test drive and at 20mph it feels like the cars about to flip over :confused: before I had DW but fixed it by toeing in the tires but now I cant get this to go away and its bad, it really feels like its just the front driver side tire and not so much going side to side as it is hoping up and down, any suggestions :confused:
     
  2. big pappa b

    big pappa b 3/4 ton status

    Joined:
    Jan 3, 2003
    Posts:
    6,328
    Likes Received:
    0
    Location:
    Falcon, Colorado
    hydro assist
    probably won't be everyone elses answer but mine is no longer noticeable
     
  3. 6.2Blazer

    6.2Blazer 1/2 ton status

    Joined:
    Feb 24, 2000
    Posts:
    4,675
    Likes Received:
    26
    Location:
    Ohio
    Make sure the u-bolts and other spring mounting brackets and bolts are tight (if the condition wasn't that bad before, always go with what you just changed as the culprit).

    If everything there goes okay, try shimming the upper kingpin springs with a couple of washers. The stock springs are not strong enough to handle big tires, so shimming them almost always helps.
     

Share This Page