Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

I got the beast going

Discussion in 'Rocky Mountain Region' started by 77ChevyK10, Dec 27, 2004.

  1. 77ChevyK10

    77ChevyK10 1/2 ton status

    Joined:
    Feb 2, 2003
    Posts:
    317
    Likes Received:
    0
    Location:
    Laveen, AZ
    i got the beast going. I blow up the TH350 a few weeks back and i just put a TH400 with a home built doubler. i will have picks up in a few days.

    Andrew
     
  2. BadDog

    BadDog SOL Staff Member Super Moderator Author

    Joined:
    Feb 24, 2001
    Posts:
    7,777
    Likes Received:
    11
    Location:
    Phoenix, AZ
    Great! Glad you got it together.

    I got mine back together and all seemed to be going better. Then yesterday I noticed what appeared to be the pan leaking. Today I traced it down, the new housing is cracked on the horizontal wall about 1" in front of the governor, above the valve body. :( I'm getting so fed up with this. I'm going to try to JB it for now, but looks like this trans is going to be a total loss after all. :mad:
     
  3. pauly383

    pauly383 Daddy383 Staff Member Moderator

    Joined:
    Jul 22, 2001
    Posts:
    16,217
    Likes Received:
    1
    Location:
    Mesa , Arizona USA
    This is good , glad to hear it . Need to see it in action :thumb:
     
  4. az-k5

    az-k5 1/2 ton status

    Joined:
    Oct 15, 2003
    Posts:
    2,774
    Likes Received:
    0
    Location:
    Phoenix AZ
    test it, try it, wheel it.
    glad to hear it.
     

Share This Page