Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

I got the shakes

Discussion in 'The Garage' started by protechk5, Dec 20, 2006.

  1. protechk5

    protechk5 1/2 ton status

    Joined:
    Sep 26, 2004
    Posts:
    2,015
    Likes Received:
    0
    Location:
    VA
    On my 1008 (k30) when I hit the brakes at speeds 25+ when I first hit the brakes it will make the whole truck shake pretty bad. It only does it 50% of the time. And if when it starts if i let off then press the brakes again it goes away, or if I hit them harder it will go away. Its just the truck that shakes, not my steering wheel, my steering is real tight. So this is just my rotors right? Or could it be my wheels?
     
  2. MattK

    MattK 1/2 ton status

    Joined:
    Jan 12, 2005
    Posts:
    1,713
    Likes Received:
    0
    Location:
    Dallas, TX
    yeah my first guess would be rotors.
     
  3. virgilh

    virgilh 1/2 ton status

    Joined:
    Sep 8, 2004
    Posts:
    343
    Likes Received:
    0
    Location:
    Sacramento California
    first off i know its repetive but check u bolts, if you find a loose u bolt check that leif spring center bolt.

    second have someone get inside your truck and shake the play out of the steering wheel turning left and right with out turning the wheels without the truck running, while you look at the draglink ends, tie rod ends looking for play in them.

    third , check the caster angle should be about 6 degrees back.

    fourth check the toe in measuerment, about 1/8 to 1/16 of a inch depending on your tire size.

    pm me with what you found because i hardly ever check the posts ive replyed to
     

Share This Page