Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

I need an answer to a question!!!

Discussion in 'The Garage' started by joshuav, Aug 30, 2005.

  1. joshuav

    joshuav Newbie

    Joined:
    Aug 30, 2005
    Posts:
    3
    Likes Received:
    0
    Location:
    sacramento
    I just got a 1985 k-5 blazer and when I acell it makes a knock knock noise then once I get up too speed the noise goes away. I just checked the pumpkin and all the rear end gears are fine. What else could it be?
     
  2. dhcomp

    dhcomp 3/4 ton status Premium Member

    Joined:
    Mar 17, 2001
    Posts:
    9,851
    Likes Received:
    280
    Location:
    Truckee, CA
    could it be the motor pinging?

    I always thought i had a bad ujoint or somethign until a mechanic said the timing was off and the sound was hte motor pinging.

    Run your tank almost empty, and put 1/2 a tank of premium in and see if the problem goes away.

    If it does, then get your timing adjusted so it won't ping on regular gas.
     
  3. joshuav

    joshuav Newbie

    Joined:
    Aug 30, 2005
    Posts:
    3
    Likes Received:
    0
    Location:
    sacramento
    I have not tryed that. Do you really think all of that metal klunking noise could be from that?
     
  4. perp

    perp 1/2 ton status

    Joined:
    Jul 14, 2005
    Posts:
    569
    Likes Received:
    0
    Location:
    Chandler AZ
    cracked flexplate will "knock" under load also. you can see it with a flashlight after pulling trans dust cover, look near the crank flange

    just a thought

    (BTW auto tranny only)
     
  5. RustBuket

    RustBuket 1/2 ton status

    Joined:
    Feb 21, 2003
    Posts:
    1,618
    Likes Received:
    0
    Location:
    Saskatchewan, Canada
    Its not an engine knock is it? Thats bad news. If it goes away when you let off tho it probably isn't.
     
  6. K5Jimmy

    K5Jimmy 1/2 ton status

    Joined:
    Sep 21, 2000
    Posts:
    1,141
    Likes Received:
    0
    Location:
    Lake Dardanelle/Logan Co, Ark
    If you have a slight shudder also....you may consider a bad tranny mount..
     
  7. big jimmy 91

    big jimmy 91 1/2 ton status

    Joined:
    Feb 21, 2004
    Posts:
    639
    Likes Received:
    0
    Location:
    Northwestern Ontario Canada
    Could be the t-case contacting the floor , like it does in my truck due to soft mounts.
     
  8. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,975
    Likes Received:
    189
    Location:
    Roy WA
    I second the flexplate issue.

    Experience I had with one was pretty similar. Any time the engine was under load (accelerating from stop, starting at bottom of hill and trying to accelerate even slowly) there would be a quite audible knock.

    It's a pretty common problem on all GM vehicles, at least the gen1 SBC.
     

Share This Page