Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

I need some pics

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by js4x4, Dec 19, 2004.

  1. js4x4

    js4x4 1/2 ton status

    Joined:
    Jul 17, 2004
    Posts:
    798
    Likes Received:
    0
    Location:
    San Diego, CA
    Hey fellas, I would seriously appreciate some pics of a TBI ( 87-ish 305 (350?) with TBI). I think I have some vaccum lines crossed up somewhere. I seriously think I have the diagram goofed up somewhere, and I don't know where...but its running like crap in gear(and at times out of gear)when idleing the lines just don't look right to me (hard lines in angles they shouldn't be in...) I just replaced the EGR....no dice (thought it may be stuck open) For what its worth , i didn't have this problem til I replaced the head gaskets. (had the whole top off...) I noted today, at start up, theres a 'whistle' noise at first, then it goes away (air leak?)

    So, some good pics of the TBI and the vaccum lines would be HUGELY appreciated. I don't know anyone else here in San Diego that I could just look at it, to see if I have em right. Thanks a million.
     
  2. opfor2

    opfor2 1/2 ton status

    Joined:
    Oct 28, 2002
    Posts:
    375
    Likes Received:
    0
    Location:
    Ventura County, CA
    I had a problem with my 90 K5 w/350 it would idle badly when I would come to a stop at a traffic light. I ended up rebuilding the TBI unit and it now runs great. I think that the injector fuel filters were dirty. Check my old posting on 90 Blazer Idle problem for further info.

    Good luck

    Dan...
     
  3. js4x4

    js4x4 1/2 ton status

    Joined:
    Jul 17, 2004
    Posts:
    798
    Likes Received:
    0
    Location:
    San Diego, CA
    I did a search....no dice man.... it points me back to this thread. FYI i know I do have a 305 w/TBI, but am guessing its similiar to the 350. A pic or 5 would be awesome really....if you have a digital camera and could take a few pics....man, i'll give you my first born child.
     
  4. js4x4

    js4x4 1/2 ton status

    Joined:
    Jul 17, 2004
    Posts:
    798
    Likes Received:
    0
    Location:
    San Diego, CA
    are there internal fuel filters in the TBI??? I already replaced the line filter.
     
  5. tx_sub

    tx_sub 1/2 ton status

    Joined:
    Mar 5, 2004
    Posts:
    548
    Likes Received:
    0
    Location:
    Denton, TEXAS
    only the in line filter. did you get the vac lines figured out yet? i just replaced some of mine and might could help you out. no digicam though.
     
  6. js4x4

    js4x4 1/2 ton status

    Joined:
    Jul 17, 2004
    Posts:
    798
    Likes Received:
    0
    Location:
    San Diego, CA
    no dice yet. Now its stalling in neutral at a light, so I really don't think its the TCC....(glad i didn't replace that too!) I have something FUBAR on this thing, and I'm getting really annoyed.

    Amazing, I don't see many Blazers in my neighborhood, but last night had one behind me, and one in front of me at a stop light! I almost got out and asked em to pop the hood!
     
  7. js4x4

    js4x4 1/2 ton status

    Joined:
    Jul 17, 2004
    Posts:
    798
    Likes Received:
    0
    Location:
    San Diego, CA
    I'll try to borrow a digi cam this weekend, and try to post em up....so ya'll can tell me whats f-ed up! Would that be better??
     
  8. supersize75k5

    supersize75k5 OrganDonorRacing.com

    Joined:
    Feb 3, 2004
    Posts:
    8,832
    Likes Received:
    4
    Location:
    gilbert az
    the wistle noise very well could be vaccume, I had a horid whistle from mine, finally found the little culprit!


    good luck!
     
  9. opfor2

    opfor2 1/2 ton status

    Joined:
    Oct 28, 2002
    Posts:
    375
    Likes Received:
    0
    Location:
    Ventura County, CA
    Yes, they are on the fuel injectors. They're a small plastic ring that cover the injector inlet holes and they have a fine filter screen on them. They are replaced as a unit.

    Dan...
     
  10. Grim-Reaper

    Grim-Reaper 3/4 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    7,385
    Likes Received:
    0
    Location:
    Atlanta
    My 88 454 has a bunch of cracked plastic lines and the gasket at the bottom of the thottle body was bad. Grab a can of carb cleaner and spray it at anything suspect while its running. The idle will change if you find a leak.

    There should be a vac diagram on the core suport or the bottom of the hood.
     

Share This Page