Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

I think I broke something!!!!

Discussion in 'Pacific Region' started by blazer88k5, Oct 24, 2002.

  1. blazer88k5

    blazer88k5 1/2 ton status

    Joined:
    Aug 23, 2002
    Posts:
    103
    Likes Received:
    0
    Location:
    Modesto, Ca
    Ok.. the 4" lift is in (spring front, block rear) install went ok, when I took it for a test ride everything seemed ok till I came to a stop sign /forums/images/graemlins/confused.gif when I let off on the gas I heard a low rumble almost a metal sound coming somewhere under the truck ????? Step on the gas it went away??? let off and there it was again?? Any ideas??? I will post some pics so you can see under, maybe someone can spot something I did wrong??? Do I need a longer drive shaft with a 4"?? I didnt think you did? just wondering, Oh ya and the yoke seems a little sloppy when I was under there taking a look.





    Thanks, Randy
     
  2. DuneRunner

    DuneRunner 1/2 ton status

    Joined:
    Aug 1, 2001
    Posts:
    1,252
    Likes Received:
    0
    Location:
    Fremont CA
    Did you drop the Tcase? (factroy spacers)

    There are little sleeves on the bolts. Use those to put between the Frame and the Cross Member. It should help the angle of the Drive line.

    Hopefully it this will help. KEN /forums/images/graemlins/k5.gif
     
  3. Chaz88K5

    Chaz88K5 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    2,979
    Likes Received:
    0
    Location:
    Stockton/Lodi CA
    more than likly you need to drop the t-case...you might even have to shim the rear end a little ....you shouldent need a new driveline but if you cant get the vibes to stop you might want to look into gettin a c/v drive shaft...that would easily take care of your prob...be sure to get the vibes takin care of quick...it will wipe out a u-joint quick...and if a u-joint goes you have the possiblity to damaging your drive shaft its self..if ya dont get it figured out by next weekend..i might have my licence back by then so i could come by and give ya a hand in figuring out the problem /forums/images/graemlins/thumb.gif
     
  4. DuneRunner

    DuneRunner 1/2 ton status

    Joined:
    Aug 1, 2001
    Posts:
    1,252
    Likes Received:
    0
    Location:
    Fremont CA
    GOOD LUCK CHAZZ. /forums/images/graemlins/thumb.gif

    KEN
     
  5. gokartergo

    gokartergo 3/4 ton status Staff Member Moderator

    Joined:
    Dec 2, 2000
    Posts:
    5,855
    Likes Received:
    0
    Location:
    Hollister, CA
    Also did you check all the bolts after you set the truck back on the ground.. You need to re tighten them all when you set it down..
     
  6. blazer88k5

    blazer88k5 1/2 ton status

    Joined:
    Aug 23, 2002
    Posts:
    103
    Likes Received:
    0
    Location:
    Modesto, Ca
    Yup everthing is TIGHT!!! /forums/images/graemlins/thumb.gif I am going to drop the t-case and hope that works... I quit driving it after I heard the noise... good thing that isn't my daily driver /forums/images/graemlins/cool.gif
    That drive line is hella short and its at an crappy angle!!

    But the cool thing is that I don't hve to say "stock K5" I can say "broke-dead K5" /forums/images/graemlins/k5.gif /forums/images/graemlins/ignore.gif LOL Well I hope this works.... if anyone has any other ideas let me know

    Thanks, Randy
     

Share This Page