Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

I went mudding today...........o sh!t i F*cked it up!!!!!!!!!!!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by NITRO, Apr 14, 2002.

  1. NITRO

    NITRO 1/2 ton status

    Joined:
    Jan 9, 2002
    Posts:
    1,057
    Likes Received:
    0
    Location:
    Frankfort In
    My second battery tipped over and all the acid leaked out making a hole in the ps hose. it ran out of fluid and i drove it home about 1 mile. is my ps pump destroyed or what?

    NITRO
     
  2. 84_Chevy_K10

    84_Chevy_K10 Banned

    Joined:
    May 30, 2001
    Posts:
    17,669
    Likes Received:
    0
    Location:
    IL, USA
    It might be. Replace the hose and put fluid in it. To bleed it, you'll have to jack the front tires off the ground and add fluid, crank the wheel back and forth, add some more fluid, crank the wheels some more, etc. If your pump still doesn't work or acts up, replace it. They're about $75 new, or you can find a used one anywhere really cheap.
     
  3. kilroy

    kilroy Registered Member

    Joined:
    Nov 25, 2001
    Posts:
    85
    Likes Received:
    0
    Location:
    Alaska, Anchorage area
    Maybe not. Replace the hose, fill it up and give it a try. The only thing you may loose is the cost of some fluid.
     
  4. NITRO

    NITRO 1/2 ton status

    Joined:
    Jan 9, 2002
    Posts:
    1,057
    Likes Received:
    0
    Location:
    Frankfort In
    it turns out the hose jusy had a small leak and we didnt notice until we tried to turn. then it was too late and we had to pull into long john silvers. but, i got it fixed and it worx ok now. so i guess i dont need a new pump. thanx for the replies.

    NITRO
     

Share This Page