Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Idiot Lights

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by MEM, Feb 18, 2001.

  1. MEM

    MEM Registered Member

    Joined:
    Feb 18, 2001
    Posts:
    30
    Likes Received:
    0
    Location:
    Long Island, NY
    I posted this on another board, but I didn't get too much feedback on it. I hope you guys can give me a hand.

    I recently purchased a 90 Jimmy with the TBI 350 engine and the 700R4 tranny. The owner before me put a set of headers along with dual exhuast system which include a set of cats and a set of flowmaster mufflers. The truck runs very good and I'm getting what I would consider average gas milelage for the size and year of the truck, about 12 to 13 mpg. BTW, it has 98K miles on it.

    A couple of days(4) ago the brake light on the dash started to flash and now the light flashes as soon as I turn the ignition over. The sequence of the flashes is the same all the time, 9 quick flashes and one longer flash. The truck brakes fine. I haven't lost any braking capability. The only thing I'm not sure about is whether the truck is equipped with ABS and has something with it gone wrong. Has this happened to any one before?

    Yesterday on my commute to home (5 miles long) my service engine light came on at about 3 miles into it and stayed on for the remainder of the ride. It did the same today and I noticed that it does it as soon as the engine gets to operating temperature(180F to 200F). Again the engine is running fine, I haven't lost any engine power or noticed any rough idling. The engine starts easily with one crank and settles to an idle quickly. No hesitation at lights. Nothing. Has the computer gone a little haywire?

    I find it unlikely that the two problems are related, but you never know. Any ideas?
    Thanks
    Manny
     
  2. kwcdawgfan

    kwcdawgfan Registered Member

    Joined:
    Jan 13, 2001
    Posts:
    91
    Likes Received:
    0
    Location:
    Georgia
    I use to have a nissan that the engine light would come on after I got down the road about a mile or two... Took it back to the dealer and they said it was no big deal just a sensor... They ordered it and replaced it a few days later... Was still under warranty so I dont know how much it cost...
     
  3. Cavalry

    Cavalry 1/2 ton status

    Joined:
    Oct 1, 2000
    Posts:
    978
    Likes Received:
    0
    Location:
    upstate NY(although I cant figure out why)
    You can run the self diags on your truck by jumping the A and B terminals of the ALDL with the ign on but not started. (little terminal box under the dash) It should flash a 12 code (one flash pause 2 flashes) 3 times and then if anything is wrong it will start spitting out codes at you. There are too many codes to put in here but I will look them up for you if you need them.


    Luke
    84 K5
    [​IMG]
     
  4. CV202

    CV202 1/2 ton status

    Joined:
    Nov 14, 2000
    Posts:
    454
    Likes Received:
    0
    Location:
    Kingfield, ME
    I have a 90 Blazer that came equiped w/ ABS. (The computer shut it off when the lift and tire size changed). Just look for a black box under the brake fluid reservoir, thats the ABS unit.

    Why do people keep calling it a Bronco!!!!!
     

Share This Page